cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 
1

Ask

2

Reply

3

Solution

Weird Twitter issue whilst using Vodafone 4g Date Sim

The_Stimulator
2: Seeker
2: Seeker

Morning all,

Bit of a weird issue here, which I'm hoping to get a bit of advice about.

I have a Vodafone 4g data sim, installed in a TP-Link Archer MR600 router. Connection is great, and I'm very pleased with the service, but over the last 2-3 days I have found I am unable to load Twitter media of any kind on an iPad or iPhone over my wifi without using a VPN, still routing in UK . Research (well ok, Google) suggested it might be a DNS issue, but what is really confusing is that the same wifi connection works absolutely fine on a Windows machine.

App deleted, cache emptied, latest iOS update applied, latest app reinstalled, same issue. Personally I don't believe this is a Vodafone issue, but trying all avenues, so Apple, TP-Link and Twitter support will also be getting asked πŸ™‚ Just trying to work my way through it.

Iain

27 REPLIES 27

CrimsonLiar
16: Advanced member
16: Advanced member

All the router does is handle data, it doesn't differentiate between Windows and Macs - the data all looks the same.  This rather suggests the fault isn't with the service or SIM but is something to do with the way your Apple devices are handling the data.

B01
3: Seeker
3: Seeker

I have the same issue.  Twitter works fine on my phone when I use my 4G virgin connection,  Immediately when I switch to mobile wifi (vodafone gigacube) no images are loaded and cannot seem to get up to date content.  Issue follows to laptop, when accessing twitter it's just a failed script error after I cleared cache, issue is definitely with vodafone only.  Internet speed is fine, fast.com reporting 15mbps.

 

facebook etc all working fine, so just twitter. For proof, tethered mobile on Virgin 4G and connected laptop, twitter working fine.  Issue defo with vodafone network.

AKCam
2: Seeker
2: Seeker

Hi

 

I have the same set up with the same issue. Its def a router or voda issue as I can tether to my phone EE service and reach twitter no problem. Tried the same fixes as you but no luck!

unoexperto
3: Seeker
3: Seeker

I just posted my question before seeing your post.

https://forum.vodafone.co.uk/t5/Mobile-Broadband/Vodafone-s-DPI-filtering-is-blocking-major-websites...

 

I have the same problem and I'm confident it's some kind of censorship/filtering system that Vodafone is testing globally because I'm seeing same problem with Lebara (different company but uses Vodafone network). It's 100% Vodafone issue and not your local problem with router/equipment.

I'm been having the same issue over the past few days, and I'm positive it is a Vodafone issue. My home broadband connection is Vodafone 4G Gigacube, and my own personal phone cell plan is Vodafone. Twitter images specifically do not load when using the Vodafone network.

 

iPhone, connected to Vodafone broadband over wifi = twitter images don't load

iPhone, connected to Vodafone 4G cell plan = twitter images don't load

iPhone, connected to VPN (bypassing Vodafone network) = twitter images load

iPhone, connected to GiffGaff(O2 network)  = twitter images load

MacBook, connected to Vodafone broadband over wifi = twitter images don't load

MacBook, connected to Vodafone 4G cell plan = twitter images don't load

MacBook, connected to VPN (bypassing Vodafone network) = twitter images load

MacBook, tethered to GiffGaff(O2 network) = twitter images load

thebeercard
3: Seeker
3: Seeker

I've seen the same issue with Twitter and am on a Vodafone Gigacube 4g.

I am losing images and the second computer in the house cannot log into Twitter.

Pasco
3: Seeker
3: Seeker

Having the exact same issue with Twitter images not loading. Vodafone connection otherwise perfect, but definitely a Vodafone issue as I can switch my phone / PC to a different ISPand Twitter back to normal immediately. 

Hi all, just resolved the issue using the apn settings from here:

https://forum.vodafone.co.uk/t5/Mobile-Broadband/Gigacube-slow-speed-and-constant-internet-drop-out-...

 

Just tried that workaround.  Made no difference to me.