cancel
Showing results for 
Search instead for 
Did you mean: 
1

Ask

2

Reply

3

Solution

5G SA (ultra) - phone not connecting

sirgader
4: Newbie

Hi!

I should be able to connect to 5G Ultra (standalone) - I meet the pre-requisites - I use compatible handset (S23 Ultra), upgraded my plan since February 23 and I tried it in several postcode covered by 6G Ultra. However my phone only connects to NSA 5G. I tried talking to the agent via chat and they suggested replacement SIM as the SIM I have is quite old. Whilst I didn't receive new SIM yet, I decided to try eSIM. To no avail. My account was plagued with several issues (as a matter of fact it still has some challenges) so I am wondering if that may be a factor. Either way I'd appreciate if anyone had suggestions with regards to getting 5G SA working.

1000105036.jpg

11 REPLIES 11

Lucy_F
Moderator
Moderator

Hey @sirgader Sorry you're facing trouble with this. So we can check over your account and your 5G connection, please pop us over a message via our Social Media Teams here. 

garetc
11: Established
11: Established

Have you received the SMS from Vodafone to say you can now use 5G SA '5G Ultra'?

If not there's no amount of contacting Vodafone CS as they don't even know what 5G Standalone is let alone know how to provision it.

The most they'll do is try to disconnect your line and reconnect it or claim that 5G is working correctly on your handset.

I have not. My understanding was that all new connections and upgrades after 24th February are automatically and instantly eligible. Otherwise it looks like the case for misleading advertising.

joesm
4: Newbie

Can you check the following settings?:

  1. Go to Settings.
  2. Select 'Connections'.
  3. Tap 'Mobile Networks'.
  4. Toggle on '5G'.

5G is working fine. 5G SA is not.

My bad. Sorry! Are you sure the location you are in covered 5G SA? Maybe resetting the network settings solves the issue 

garetc
11: Established
11: Established

If the service hasn’t been provisioned i.e. the user hasn’t had the SMS no amount of users changing the settings will help. Not even CS, if half of them knew what it is, can enable the service at the moment, option isn’t available for them to enable it. 

It is disappointing, mildly speaking, that despite meeting all the pre-requisites, it will only be enabled at Vodafone's mercy. Reading the website again there is mention of the text notification, however I read it that it was for the existing customers (e.g. not upgraded lines). Doesn't seem like it's explained clearly enough.

Besides there must be someone in the organisation who can force manual provisioning. "Computer says no" explanation doesn't make the cut. Unfortunately I must agree that hardly anyone even knows what 5G SA (Ultra) is...

I am sure. Tried at least 7 postcodes - even had the mast within the visual line of sight. No luck. The most my phone connects to is "NR NSA".

Network settings were reset as per CS agent advice too.