Showing results for 
Search instead for 
Did you mean: 






Can not continue checkout process at all.

3: Seeker
3: Seeker

After adding a plan to basket, I want to checkout and review the order.

And there is a weird issue. I've tried it in different browsers (Edge, Brave, Chrome) None of these work.

I've attached an image about the issue:



The Name and Nationality fields are missing. I can not edit them at all.

Without editing them, I can not click the "continue" button below and I'm stuck here.

Hopefully it could be fixed asap. Otherwise this will keep blocking users.


3: Seeker
3: Seeker

Here are some details regarding the issue.

I'm an existing customer and trying to upgrade from pay as you go.



After choose an additional plan, it enters checkout page. And that's the issue:


Name & Nationality can not be edited. And I always stuck at here. Can not click continue button.

Hopefully this information can help you debugging. I think all existing customers are affected.

Community Manager
Community Manager

@SquallLiu - thanks for providing this information and sharing the journey you’re having online. Have you been able to test this again this afternoon? I can see you’ve mentioned you’ve tried it from different web browsers. Please can you also test clearing your cache and cookies and from a different device if possible?

Yes, just tried them on a different PC and also my phone with cache & cookies cleared.

It's still not working.

I am having the same problem and spoke to customer service who were not helpful at all who blamed it on a third party site which redirected me to Vodafone site to complete the order. Even without the referral I am having the same problem.


tried different browsers and different machines which suggest there is a bug in their code not the end user. I work in IT and I must admit not impressed with Vodafone 

It's disappointing to see your concerns and feedback @MartyArty. We understand how both frustrating and concerning this must be. You've stated that you're experiencing the same problem in this thread reported to us in August 2022. To both double-check and to make sure that we're on the same page, are you also unable to enter your name and nationality into a required field?

Hi there, I'm having the same issue. I've tried different devices, clearing all cache/cookie etc history. The site will not allow me to enter my name. I am logged into my account. I can alter email/phone number/nationality. Date of birth is already filled in. It will not allow me to enter my name therefore I cannot continue with the checkout of my uprade.

Hi @KATHERINEWINCOT Thanks for raising this with, sorry you're facing trouble placing your upgrade. Can you please try this via a incognito / private browser session, or a different browser entirely to see if issues still occur? Is your name not pre-populating in the name field? 

Hi Lucy, I’ve tried on 3 different devices, private browser, chrome, internet explorer, safari. None of them let me fill my name in & it is not already in the name field either - it’s just blank - there is no name box for me to fill in. I’ve attached an image to show you the issue. As you can see the name box doesn’t exist.


@KATHERINEWINCOT - thanks for the tests you've already done and the example you've sent over. My team can look at discussing an upgrade with you over the phone and also raise the issue you're facing. Please get in touch with us on Social Media. Alternatively, you can call our Upgrade team on 191 free from a Vodafone mobile or 03333 040 191 from a different phone.