cancel
Showing results for 
Search instead for 
Did you mean: 
1

Ask

2

Reply

3

Solution

Broadband App issue

ClassicMan
2: Seeker
2: Seeker

I have recently been sent a new router as the speed of the old one was never consistent or near the promised speed.  Having installed the router and started up various devices on the network things were looking good.   I then tried to log into the router admin page just to check the device map.  That when the problems started.  I could not login.

Via the Chat line I conversed with a guy called Osang who after nearly an hour admitted that Vodafone are having problems with the new router/website and that I should use the Broadband App on my mobile.  This I did, that doesn't work either.

You can go through the login process until you get to the message 'Setting up your app' and then getting the ! mark in the triangle and the text 'Something's going wrong'  'try again'.  It does that repeatedly and the only way to stop it is to go to the installed apps page of settings, force a stop, uninstall the app, reinstall the app, start the app and go through the whole tedious process again and again and again.....

Has anyone found the same problem and found a solution please?

5 REPLIES 5

Jayach
16: Advanced member
16: Advanced member

Firstly, which router did/do you have? The THG3000 or the Ultra hub?

Definately try a factory reset of the new router.

ClassicMan
2: Seeker
2: Seeker

Thanks Jayach.  I have the THG3000 Router. and I have done the Factory reset and changed the password for the Router/Hub (it is very confusing that they interchange these 2 names) and I have changed my Wifi password.  I have been round and connected all my devices via the new Wifi password.  So far so good, but I still cannot get the Broadband app to work on my phone.  Looking a little more at the their website they do acknowledge that there are problems with it.  For a technical communications organisation Vodafone are really the pits.

Jayach
16: Advanced member
16: Advanced member

Ah, so you can now log in to the hub? So its just the app that is causing problems?

Personally I much prefer to use router's GUI for administration purposes, never have liked the app.

As for calling it a hub, it's due to it being a modem and router combined, so really it can be confusing to simply call it either of those names.

What device are you running the app on, iOS or Android? The Apple version doesn't really seem to work with the THG3000, it seems to be tailored for the Ultra hub.

ClassicMan
2: Seeker
2: Seeker

I am old school, a modem is a modem and a router a router.

I was trying to run the app on a Vodafone Android phone.

Thanks for your help on this, I now have a device map for my records and have assigned the app to the waste bin.

Jayach
16: Advanced member
16: Advanced member

@ClassicMan wrote:
I am old school, a modem is a modem and a router a router.

Yes, but what do you call it when they are both in the same box?🤔