main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Other broadband queries

Can't get my USB Print Sharing to work

SOLVED
View solved solution
Highlighted
2: Seeker

Hi. I've searched but can't find the solution.

 

I have the following spec:

THG3000G router

Windows 10 64bit

Lexmark MS312dn printer (no WiFi capability)

 

I have plugged in the printer tothe router, the router USB sharing is switched ON and the router sees and recognises the printer.

I have installed the printer on the PC so the correct drivers are there and I've confirmed it to be working by connecting with USB directly to the PC.

When I connect the printer to the router the PC can no longer see the printer. It is still set as my default printer but shows as "offline", i.e. the PC can't see the printer. The printer is switched on and connected to the router at this stage.

Can someone please explain how to enable printing through the USB port on the router. If it's a case of configuring the port in the router I'll need a step by step guide.

Thank you.

 

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
16: Advanced member

There is no guarantee that it'll ever work because Vodafone don't support using the USB ports on the router(s) for anything other than their own Mobile data dongles!

 

If it is going to work, you'll need to dive into the Printer Properties (Control Panel>Devices and Printers) and change the port in there that your computer thinks the printer is connected to.  You do this by right-clicking the icon for the printer and selecting "Printer Properties".  In all likelihood you'll have to set up a new TCP/IP port for the printer, using the local IP address of the router!

 

If it's going to work the above should do it, though to be honest, it's a few years since I last set up a printer that didn't have it's own WiFi or Wired network connection!

View solution in original position

View more options
2 REPLIES 2
Highlighted
16: Advanced member

There is no guarantee that it'll ever work because Vodafone don't support using the USB ports on the router(s) for anything other than their own Mobile data dongles!

 

If it is going to work, you'll need to dive into the Printer Properties (Control Panel>Devices and Printers) and change the port in there that your computer thinks the printer is connected to.  You do this by right-clicking the icon for the printer and selecting "Printer Properties".  In all likelihood you'll have to set up a new TCP/IP port for the printer, using the local IP address of the router!

 

If it's going to work the above should do it, though to be honest, it's a few years since I last set up a printer that didn't have it's own WiFi or Wired network connection!

View solution in original position

View more options
Highlighted
3: Seeker

Did you get this to work, AnimalMother? I've been trying most of today and I've finally just worked it out!

My printer (an Epson DX6000) doesn't have wireless and only has a single USB connection, which I plugged into my Vodafone Wi-Fi hub. The hub appeared to recognise it, but my computer couldn't find it. It turned out that the hub actually assigned my printer an internet address! Once I discovered that, it was relatively simple to get my computer to find it. 😁  

View more options