Showing results for 
Search instead for 
Did you mean: 






Files and Folders Missing in USB Share on Vodafone Ultra Hub

2: Seeker
2: Seeker

I have set up USB file sharing from a Vodafone ultra hub. This is to share music through Sonos. Many of the albums do not show up in Sonos. The same files and folders belonging to the tracks also do not show up In Microsoft Windows when the drive is mapped. If I try to create a new folder on the Network Drive in Windows with the same name as one that does not show up the action is prevented. If I tweak the name by including an extra character in the name then sometimes the 'missing' folder appears. But this setup is not stable, and it quickly disappears again. I have tried deleting what appears to be the database created by the router on the usb drive called .mvfs\tagdb but there are still the same missing files. I thought that is might be something to do with too many characters in the file path, but this is not the case because some missing files have path lengths smaller than those that are visible and work. If I connect the USB drive directly to Windows PC then all files appear visible and uncorrupted. I have tried both the USB A and the USB C sockets and both behave the same. I previously attached the USB drive to a Vodafone THG3000 router and it worked OK. Any ideas what I am doing wrong or how to fix it?