Showing results for 
Search instead for 
Did you mean: 






New App is a Total Disaster

2: Seeker
2: Seeker

My iphone updated the Vodafone Broadband app yesterday - and the new version is beyond awful. It tells me that boosters aren't working (when they are) and also I can no longer see the mesh configuration of my network (I have 4 boosters in a big house).

This app should not have been released.


4: Newbie

Hi, I'm on Android but agree thaat the Ap  was no use at all. However that wa when I was using the 'older' THG3000 router. Last week I was upgraded to the 'New' Euro 6E router and the ap has been restored to full function. (Even tho its still the same version of Ap). I'm afraid, I think the Ap is now only of use on the New Euro 6 routers that are the current Vodafone standard.

16: Advanced member
16: Advanced member

This app has been updated to bring compatibility with the new router. Unfortunately, it seems, it was never tested on the old hardware - that or vodafone just don't care.

It's the same with IPv6, only new clients are getting it. 

2: Seeker
2: Seeker

The new broadband app. I cannot believe Vodafone. I went to log on this morning to find that the new app did not recognise my account, then, after I managed to log in it states that my hub is not functioning. What a useless time waster. VODAFONE GIVE US OUR OLD APP BACK  

2: Seeker
2: Seeker

I got exactly the same issue (Android App). Tried to connect and it told me my router wasn't working. Uninstalled and re-installed the app, and now it won't even "pair" with my router - it's as if it can't even see it on the network and wants me to connect to the WiFi network on which the router is (it already is!!)

Wouldn't mind if I could make changes on the router itself via the web interface, but because "Super Wi-Fi" is enabled, it refers me to make changes in the app - I CANT BECAUSE YOU BROKE IT!!!

Utter dogsh1t.

16: Advanced member
16: Advanced member

This App mess seems to me to be similar to the mess Google have made of Fitbit since the takeover. I wonder if this is preparatory work for the merger that may not even happen.

4: Newbie

I’m having the same issue. Contacted the WiFi experts who reset my router twice told me the app was working and when I said it wasn’t ended my chat session.

The interaction between the hardware and software is terrible.

2: Seeker
2: Seeker

I signed up simply to state the latest app is nigh on useless. I have no idea how to feed this back but for anyone with the slightest technical knowledge it is utterly pointless. The old one was almost good as you could actually do some configuration using it (lose points due to the general dumbing down of being able to configure the router - namely split the SSID between 2.4Ghz and 5Ghz to support IoT), the new one is terrible. The router now references capabilities that are not in the app.