Showing results for 
Search instead for 
Did you mean: 






Smart devices unable to connect to Ultra Hub Wifi (Eufy Doorbell and AudioPro speakers)

3: Seeker
3: Seeker

I've recently moved back to Vodafone, and had my FTTP service activated yesterday, with the Ultra Hub and Pro WiFi.

Laptops, phones and tablets are working just fine, but I have a few smart devices that refuse to connect, specifically a Eufy Video doorbell ( and several AudioPro multiroom speakers (

On both of these, you use the manufacturer's mobile app to choose a WiFi network and provide the password, then they should connect, but it just fails every time. They were all working just fine on Tuesday with my BT Hub so it looks very much like a compatibility issue with the Vodafone router.

I have tried using WiFi compatibility mode on the Router but that's made no difference, and have had some incredibly painful chats with the support team who have insisted that WiFi won't work properly in the first 48 hours until the service is fully activated, or that the problem is with all my devices. They also seem to disagree about whether I have the Pro WiFi or not, and suggested that might be stopping things connect. They did offer to send another WiFi booster in case it's a coverage issue, but that's not the case as these are a matter of meters away.

Has anyone seen anything similar with smart devices that refuse to connect, and if so, how did you solve it?

In the event log I can see errors like
"Failed to send to ff02::1%guest@br-guest (Cannot assign requested address)" and "Ignoring MLD pkt on non snooping enabled bridge interface lan"

The tech support team didn't seem even remotely interested in looking at those.

If this can't be fixed I'm going to need to leave Vodafone, as the service is not fit for purpose and I'm not going to abandon £1K's worth of equipment that can't connect, but I don't imagine that's going to be easy.


3: Seeker
3: Seeker

It’s only gone and worked!   
Renamed the guest WiFi to what I plan to use as the main SSID and joined the devices, then flipped the names over and so the main network has the right name and it reconnected just fine. 

<insert huge rant about how a Pro WiFi service shouldn’t require an IT professional with twenty years of experience to figure out a trick like this, or how the online chat support was so infuriating it nearly reduced me to tears>

Hopefully this will save someone else the headache. Thanks to all of you who offered suggestions which helped nudge me towards a solution. 

View solution in original position


1: Seeker

Hi all, I also have a Roberts i93 which was not working with the new Ultra hub I recently got. The above solution with SSID's did not work for me. But I found another workaround. In this case I do have compatibility mode turned on, but I don't know if that is essential as I hadn't tried it with that mode turned off yet.

After attempting to pair with WPS, the router's purple light turned to green indicating that it had worked at that end, but the radio said it could not connect. By chance I looked in the radios network config screen and noted that the details set by DHCP were all wrong invalid addresses. So I tried the slightly laborious method of setting it up without DHCP assigning a random address , setting the subnet mask and for simplicity sake, using cloudfare DNS servers as they are easier to key in.

The radio connected straight away so it seems there is some sort of issue in the DHCP set up for some devices. I hope this helps anyone else having similar issues!