Showing results for 
Search instead for 
Did you mean: 






Pro II hub problems - has anyone made it work?

2: Seeker
2: Seeker

Made terrible mistake “upgraded” from my old Vodafone router which worked fine to a Pro II. What an oversized, over hot (running cost?) piece of junk. Five days on from activation it’s still not working right. Initial set up worked OK, but of course had to reset 3 smart TVs, firesticks, smart speakers, Ring doorbell + cameras, CCTV, change default passwords phones, tablets etc etc. Very time consuming. BUT on completion - no working digital voice land line! I’d had to rewire the intruder and fire ADT system in anticipation as our house isn’t insured without it. Get through to India after the lengthy tedious security checks then 1hr doing endless hard resets losing all the set up work I’d done on connected devices + linking up a video connection with a 2nd mobile, ending up with not only problem not fixed but broadband service now lost along with my old landline connection! Following day repeat performance with someone else on phone for 1hr 20mins with no success so the lady organises an OpenReach Engineer so we had to stay in for him following day. He spends 3 hrs on problem, he talks to India and gets broadband back up but still no digital voice. He’s told a next level engineer will phone. Which happens next day but yet another endless cycle of security checks and the agonisingly slow reboot time of the router but not fixed and I’m told top tier engineers would fix it today but they haven’t. Meantime each call I ask for an extra booster to be sent but am told it can’t be done until I have a working service. Last request I’m told to go to a Vodafone shop but when I do they say I should order direct by phone! But they are very helpful spending 25mins on the phone on my behalf to be told that it has to be me phoning “expert wi-fi” tomorrow to get one! So now I have no phone and no house alarm and I suppose I’ll have to ask for them to reinstate the old non digital landline connection. More time on the phone. Anyone else had this problem and if so was it fixed and if so how?