main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

Wifi Calling not provisioned on handset (Xcover4)

SOLVED
View solved solution
Highlighted
3: Seeker

I recently purchased a Samsung XCover4 on contract through Vodafone, I need a rugged handset and WiFi-Calling.  The Wifi Calling feature is enabled for my account but the OTA configuration to enable the service does not appear to have been sent out or received correctly as the software toggle for the service has not turned up in my Phone Settings.

 

After days of going around the same loop of asking for it through the social media team, online chat and by calling 191, the setting has still not appeared.  I have tried resetting the phone to see if I had made a mess of it.  I have been to Samsung Support to have the software re-applied to no avail.  I went to a Vodafone store and they were just as stumped.  In the meantime, calls break up or are easily dropped and Vodafone is the best reception of all the networks locally.  Mind you, I do not even live in an especially rural area.   

 

This phone is listed and advertised as supporting it.  I got it directly through Vodafone to avoid configuration issues.  What has been omitted?  "It should just come on".

 

It is running Android Oreo 8.1.0 with the September 2018 updates.

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
3: Seeker

The technical teams had been working on it.  By this morning, the option appeared in Phone...Settings just as it should have done straight away.  And it appears to work as expected.  Clear calls indoors at last on WiFi and 4G Calling should be available, too, when I am out and about. 

 

Although I understand that a recent upgrade to an adjacent cell tower 1658900 57417 has cleared a network bottleneck and I am actually getting both 2G and 3G passibly at home indoors from 47511835 126, which was not the case a month ago.  Not quite a stable 4G signal from there, but more calling options are covered now when I could not keep a calling going at all before.

20190322_140422.jpg

View more options
11 REPLIES 11
17: Community Champion

Well this is a conundrum @alanjenney  as it should work if a person is using a compatible phone and eligible tariff.

 

This is some advice I picked up on a while ago.

 

Calling Over WiFi Set up.

 

Ask the agent to force the phone via sending an OTA configuration update that should provision your phone for Calling Over WiFi. 

 

"Register for Vodafone Wi-Fi Calling

Text the word CALLING to 97888

This is a free text which will add the service to your account

You should receive the following confirmation text:

Thanks. We’ll add Wi-Fi Calling to your account in the next 24 hours and will let you know when you’re all set up.

If you’d like to discuss this with us, or if you have any other issues, you can find more info here or contact us

Once you receive the confirmation text, switch on Wi-Fi Calling in your settings

Go to Settings, scroll down and choose the Application icon

Choose Phone and scroll down until you see Wi-Fi Calling – select the box beside this option

A pop-up will appear asking you to confirm if you want to enable Wi-Fi Calling – tap OK "

 

The Vodafone Social Media Teams here might be able to help you once they've caught up with your thread too.

Current Phone > Samsung Note 9 _512Gb > Model: SM-N960 Hybrid-Duos.

Samsung One Ui  / Pie.

 

Samsung Gear s3 Frontier Watch.

View more options
3: Seeker

Thank you for a quick response, it's all along the lines of my expectations.  It's all very familiar. 

 

I have been round this loop several times with agents on Webchat, on the phone on 191, with the social media team from contact through Twitter and I have been to a Vodafone shop where they confirmed that the handset is listed as compatible along with the absence of the setting.  I have been told that other customers have the service, but I have also been told at the shop and in online forums that other customers have experinenced similar issues . 

 

I have explicitly used the terms 'over-the-air' 'software configuration update' and so on, the agents have stated that they understand my expectations and claim they have sent it.

 

All the agents have tried removing and re-applying the service.  I have tried removing and re-applying the service through the 'My Vodafone / My Account' website, through the My Vodafone app, waiting around 24 hours before making contact again and I have been asked to send that text message and have received that initial confirmation in excess of ten times, multiple times yesterday.  The instructions that you have quoted at the end of that massage are similar to the steps on the Vodafone website explicitly for my phone* and the setting is not there.

 

It's been about two weeks.  But the anticipation of getting WiFi Calling goes back a couple of years.  Hence my frustration.

View more options
Moderator

You’ve certainly not had a great experience with this @alanjenney, and it does sound like just about everything’s been checked which is really unfortunate.

 

There is one other thing though. I’m not sure if this will apply to your particular handset, however some phones will use VoIP (4G calling) in preference to Wi-Fi calling. When a 4G signal’s showing, and the phone can make a call over 4G, the Wi-Fi calling feature is hidden. Can you trying switching down to 3G or 2G mode, doing a quick power off and on, and then check for the Wi-Fi calling option again?

 

Blair

View more options
3: Seeker

Neither 4g calling nor Wifi calling has been provisioned on the handset, despite the "4g and WiFi Calling" being set on my account.

 

I have experimented with selecting the band used with no difference.  It does not even try because the feature is dormant and needs to be enabled by Vodafone.  I have had this confirmed at the Vodafone shop and local Samsung Support Centre.

View more options
Moderator

I'm sorry you've had problems getting Wi-Fi Calling added to your services @alanjenney. As we'll need to access your account to see if this has been provisioned correctly, please get in touch by following the instructions in this private message and we'll be in touch.

View more options
3: Seeker

I followed the instructions in the private message, but I have had no further contact.

View more options
Moderator

@alanjenney I'm sorry to hear you've not yet received a reply. 
Please let me know your reference number, from when you contacted us. It looks something like this [#12345678] and can be found in the subject line of the automated confirmation email, you should've received. 
Once I have this, I'll be able to chase everything up for you 😊

View more options
3: Seeker

Before I was notified of your reply in the forum, I had a second go at submitting the web-based form.  I got the same splash screen on the web page thanking me for contacting Vodafone, but this time I also got an email acknowledgement, which contained the number #20547453.  Hope this has gone through this time.

View more options
Moderator

That's great @alanjenney, thanks for confirming your case reference. We've got the email you sent earlier today, one of the team will be in touch as soon as possible.

View more options
3: Seeker

The technical teams had been working on it.  By this morning, the option appeared in Phone...Settings just as it should have done straight away.  And it appears to work as expected.  Clear calls indoors at last on WiFi and 4G Calling should be available, too, when I am out and about. 

 

Although I understand that a recent upgrade to an adjacent cell tower 1658900 57417 has cleared a network bottleneck and I am actually getting both 2G and 3G passibly at home indoors from 47511835 126, which was not the case a month ago.  Not quite a stable 4G signal from there, but more calling options are covered now when I could not keep a calling going at all before.

20190322_140422.jpg

View more options
Moderator

@alanjenney It's great to hear your Wi-Fi Calling is now working and that there's also been improvements to the signal in your area 😊 Thanks for taking the time to let us know. 
If there's anything you need help with in the future, please don't hesitate to pop back to us here. 

View more options