Showing results for 
Search instead for 
Did you mean: 






Broadband app connectivity

2: Seeker
2: Seeker

I have had trouble continually with connecting to my router even before the new version of the app. I get “ router is offline “ errors all the time now when trying to connect, and I know it isn’t because all devices are working. My phone is iPhone 11, however when I try using my wife’s iPhone 8 all is well. I have done all the usual - turn off/on, (both phone and router), deleted and reloaded app, tried the helpline with no success whatsoever merely that “it’s just one of those things “. 



Hi @stuartdixon thanks for raising this to us. Are still facing trouble, are both the iPhone 11 and iPhone 8 running the same version of the app? You've mentioned you've already tried removing and re-installing the app. If you turn the mobile data off on the effected iPhone do you still get prompted with the same error? 

Thank you for your reply. Both phones have the same, uptodate version, (I had the error with the previous version, I never tried it on the iPhone 8), and yes, still an error when mobile data switched off. 

Any progress on this please? My contract is now due for renewal and I am not sure whether to do so in view of the situation. 

Community Manager
Community Manager

I'm sorry to hear you're experiencing difficulty connecting to our app on your phone @stuartdixon. It sounds like you've tried many of the general troubleshooting steps. As we'd need access to your account to take a more in-depth look into this, please reach out to us Tech team by calling 0333 304 0191 from and UK number, or reach out to our Live Chat team and we'll be happy to take a closer look.