Showing results for 
Search instead for 
Did you mean: 






OneNumber not working on Apple Watch after phone contract renewal

3: Seeker
3: Seeker

I have been using an Apple Watch series 6 with an IPhone 13 and OneNumber account for about a year. About a month ago, my contract ended, so I chose to renew it. So far so good. 

However I then noticed that my (cellular) watch wasn’t working online when away from my phone. 

Looking at my watch’s mobile data status, it shows Plan as Vodafone and Status as Connected. I have OneNumber enabled on my account and am paying for it monthly. 

I spent the usual 1 hour + on Chat with Vodafone support and they took me through the process of (re)activating the eSIM on my watch (by entering its EID into the SIM Swap function on the website). I received emails saying “We’re working on your SIM swap request” etc. 

I then unpaired and re-paired my watch with my phone. 

Result: no change. 😤

Today, I’ve had another go at doing a SIM swap and re-entering the same EID again. No change. I did get a few ‘Server error” messages from Vodafone’s website in the process.  I’ve now gone in and removed my data plan altogether, thinking I may be able to add it from scratch. But it won’t work. I now have “No SIM” and “No connection” in the Mobile Data section on my watch. When I try to add a data plan, it takes me to a page for subscribing to a (presumably new) OneNumber account and when, in frustration, I proceed, it just hangs or crashes with a server error. 

Can anyone point me at a page which gives step-by-step instructions on how to re-attach an Apple Watch to an *existing* OneNumber account?


And perhaps Vodafone could have a look at their Provisioning system to see why contract renewals aren’t carrying forward existing Apple Watch OneNumber accounts. 

Many thanks in anticipation 




Hey @Jezzer22 I hope you're well! So we can look into this further and help get your watch up and running again, please drop the Social Media team a message here

4: Newbie

@Jezzer22  did you get this sorted? If so, how?

I’m having the same issue. Trying to get my new Apple Watch Ultra using my OneNumber. I went through the SIM Swap form and provided my new EID number. I’ve also called 191 and they have continued to tell me it can take 24 hours. That was 72 hours ago, and counting.


Ridiculous process.

I’m not absolutely sure about this, but I eventually was connected with someone in tech support. They took me through the well-worn process of unpairing and re-pairing the watch from my phone, but this time asked me to put my phone on flight mode, make sure Bluetooth was off and then restart the watch. After all that, I opened up an app that requires connectivity and it worked! I guess disengaging the phone from the watch and restarting the watch may have forced it to look elsewhere for a connection. Hope this works for you. 🍻

Thanks @Jezzer22 — what a crazy convoluted process 😡


I really don’t want to have to unpair and re-pair the watch again, it takes too long.

I felt the same way but if you skip adding your credit cards until the problem is fixed, it’s really not too bad. 

Hi @Jezzer22 at what point in that process did you need to put the phone into flight mode? After the unpairing and re-pairing the watch from your phone?

And also regarding "I opened up an app that requires connectivity and it worked" — what app are you referring to?

TBH I don’t recall exactly but, thinking through the mechanics, I presume I unpaired,re-paired and then switched on Flight Mode on my phone and then reset the watch. Doing this would cause the Watch to reboot and find no connection available via the phone. I’m guessing this forced it to open its own connection to the Internet, rather than default to the phone’s (which consumes less battery power)


Any app which requires access to the Internet would do. I think I tried a few. Some require the corresponding iPhone app to be open on your phone and therefore a connection between your watch and phone (the one thing you’re trying to prevent). I think I ended up opening Apple Maps on my watch, which successfully loaded a map. 




Thanks @Jezzer22 

Quick update on this. I finally got my new Apple Watch working, however...


Really bad experience. I was without service for 5 days, and every day I called they told me the SIM swap would be sorted in 24 hours. This issue finally got sorted. But it was me who suggested the solution. I told them to cancel my active OneNumber subscription (which was the old one). Once cancelled (within a few minutes) I then simply enabled Mobile Service on my Apple Watch app on my iPhone (as you would do with a new Apple Watch OneNumber subscription). This worked straight away.


Long story short — the Vodafone SIM Swap service/process for eSIMs and Apple Watches does not work. Not just for me, but for my brother and many others online who have experienced the same issue.