main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Sony Xperia 1 mk iii

SOLVED
View solved solution
barrysmith1010
2: Seeker

Hi, any advice how to get the new Xperia 1 iii provisioned with WiFi calling, I have tried all the usual stuff, using the app, and Voda support resetting the provisioning, but still the option does not appear in the phone settings. I'm guessing it might be that there's no profile setup for this device, but is there any way around this?

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
BandOfBrothers
17: Community Champion

It might be because the phone hasn't been added to the eligible list on Vodafone wi-fi-calling 

However we have seen phone's that can support calling Over Wi-Fi work anyway.

The trick is to get a Vodafone Agent to sent an Over the Air configuration and make sure then it's turned on in your myvodafone.

Register for Vodafone Wi-Fi Calling
Text the word CALLING to 97888
This is a free text which will add the service to your account
You should receive the following confirmation text:
Thanks. We’ll add Wi-Fi Calling to your account in the next 24 hours and will let you know when you’re all set up.
If you’d like to discuss this with us, or if you have any other issues, you can find more info here or contact us
Once you receive the confirmation text, switch on Wi-Fi Calling in your settings
Go to Settings, scroll down and choose the Application icon
Choose Phone and scroll down until you see Wi-Fi Calling – select the box beside this option
A pop-up will appear asking you to confirm if you want to enable Wi-Fi Calling – tap OK"
Make sure Calling Over Wi-Fi is turned on in your myvodafone.
Calling Over Wi-Fi will only activate when there is no network connection. Test by activating Flight Mode on your phone.

 

Current Phone >

Samsung Z Fold³ 5G.

Previous Phone >

Samsung Note 20 Ultra 5G - SM9860.

View solution in original position

View more options
4 REPLIES 4
BandOfBrothers
17: Community Champion

It might be because the phone hasn't been added to the eligible list on Vodafone wi-fi-calling 

However we have seen phone's that can support calling Over Wi-Fi work anyway.

The trick is to get a Vodafone Agent to sent an Over the Air configuration and make sure then it's turned on in your myvodafone.

Register for Vodafone Wi-Fi Calling
Text the word CALLING to 97888
This is a free text which will add the service to your account
You should receive the following confirmation text:
Thanks. We’ll add Wi-Fi Calling to your account in the next 24 hours and will let you know when you’re all set up.
If you’d like to discuss this with us, or if you have any other issues, you can find more info here or contact us
Once you receive the confirmation text, switch on Wi-Fi Calling in your settings
Go to Settings, scroll down and choose the Application icon
Choose Phone and scroll down until you see Wi-Fi Calling – select the box beside this option
A pop-up will appear asking you to confirm if you want to enable Wi-Fi Calling – tap OK"
Make sure Calling Over Wi-Fi is turned on in your myvodafone.
Calling Over Wi-Fi will only activate when there is no network connection. Test by activating Flight Mode on your phone.

 

Current Phone >

Samsung Z Fold³ 5G.

Previous Phone >

Samsung Note 20 Ultra 5G - SM9860.

View solution in original position

View more options
barrysmith1010
2: Seeker

Hi,

Thanks for all the info - the process you describe is exactly what I have done so far with no luck.

I did see the OTA profile come down after a chat with the support team and after a reboot I thought that would be it but sadly not. I think its going to be a waiting game!

 

Thanks very much for your help, once it's solved I'll update in case others are having the same issue.

 

 

 

View more options
barrysmith1010
2: Seeker

Hi,

 

All working! it took about six hours but eventually I got another text message and after a reboot WiFi calls option appeared. So for anyone else with the same device - follow the steps in the thread and it should all come good.

 

Thanks,

 

Barry

View more options
Steph
Moderator

Thanks for updating us @barrysmith1010 I'm so glad to hear that you got this sorted! 😊 It's great to know that we have a solution now incase anyone else experiences the same problem 🙂

View more options