main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Wi-Fi calling on Samsung Galaxy S8

3: Seeker

I have just got a Galaxy S8 on a Vodafone Pay Monthly tarriff that supports Wi-Fi Calling.

First of all I have to say that the support team at Vodafone were not at all clear on how you enable it on the phone.  I eventually found out that the option to turn it on lies here:  

Go to Settings then Apps then select "Show system apps" from pull down menu. then scroll down to the Phone app (the first of 3 with the largest storage figure (580 Kb in my case), then select More settings, then scroll down the screen where you will finally find the W-Fi calling option.  This is all assuming that Wi-Fi calling has been enabled for your Vodafone account at the server.

 

Having done all that, I then find that it simply does not work properly if you have a mobile signal as well as being connected to a wif-fi network.  It switches itself to Wi-Fi calling sometimes even when you have a good mobile signal and when that happens you can make calls but the receiving end can not hear you even though you can hear them perfectly.  In addition any numbers you press, say when you are trying to respond to automated questions when calling Vodafone support, are simply not "heard" by the other end.  

I can make it work perfectly well if I put the phone into "flight mode" to disable a mobile signal altogether while maintaining a wi-fi connection.  

My wife has an iPhone on the EE network and hers behaves exactly as should be expected. 

Does anyone else have this problem or is it a fault with my actual Galaxy S8 handset.

Thanking you in anticipation

John

 

View more options
6 REPLIES 6
17: Community Champion

Hi @vahgatsi

 

Thank you for sharing the information in how to find Calling Over Wifi on the samsung s8. 

I have the Samsung s8 too but use it with a Payg SIM card so cannot try mine for you. 

That said most phones imo will try to connect to the strongest available connection it thinks is the best which is why it's possibly switching. As you've found out turning on flight mode resolves that issue. In regards to the other related hiccups I've not heard of this occurring before. 

The Social Media Team here read all posts so I'm sure this will be fed back to the relevant department. 

Current Phone > Samsung Note 9 _512Gb > Model: SM-N960 Hybrid-Duos.

Samsung One Ui  / Pie.

 

Samsung Gear s3 Frontier Watch.

View more options
10: Established

may be worth reading this post as it is happening to loads of us and vodafone are meant to be sorting it out but i would not hold my breath https://forum.vodafone.co.uk/t5/Android/wifi-calling-s8-plus/td-p/2558107

View more options
2: Seeker

 

@vahgatsi

 

So basically you are on the right track. 

 

Step 1 get Vodafone to activate wifi calling on your account. 

Step 2 the settings you have just mentioned. under the file wifi calling turn on the permissions.

Step 3 go to this you tube link follow instruction https://youtu.be/00ZT_Uqf5AE

 

Thank me later

 

View more options
2: Seeker

Step 1 get Vodafone to activate wifi calling on your account. 

Step 2 Go to Settings then Apps then select "Show system apps" from pull down menu. then scroll down to where you will finally find the android wifi file. 

Click the file and turn on the permissions at the bottom.

Step 3 go to this you tube link follow instruction https://youtu.be/00ZT_Uqf5AE

 

Thank me later

View more options
2: Seeker

Firstly John you are a star as you have helped me turn on wifi calling on my s7 in 2 mins...... Versus nearly an hour on chat with agents that never once mentioned unhiding system apps! I had to text CALLING to 97888 to get it set up from Vodafone end though. Got confirmation text back and set up text a couple of hours later. Hope that helps 

 

View more options
2: Seeker

John, you are a star.  

My suresignal just stopped working and I get a poor signal at home, so I need it To work or wifi calling.  No one at Vodafone or in a load of forums could simply explain why the options on the new s8 they supplied me as an upgrade on my contract, were not there to enable wifi calling as they said.  Unbelieveable, they must be making it up or copying from another Samsung phone without actually checking.  This is a Vodafone supplied phone as well and all software up to date on it.  Of course you have to have it enabled on your account, which is per instructions, so that was always enabled and I switched on in my account some time back but checked again it was  I was just never able to enable it on my previous s7 edge or this phone in any of the settings menus they advised nor were Vodafone able to so they sold me a secure signal! Yes sold me not gave me for free. I will be asking for a refund and as it has also failed within 2 years warranty.

so all along this could have been enabled.  Perhaps they should consult people like yourself who figure it out and do it before they say a way to do it that clearly doesn't work and  waste a lot of people's time.  Maybe it's to boost sales of sure signal 🤔 🤑

The people at Vodafone are paid to figure out and provide this stuff.  They should put incentives and give reward to people supplying the community with information around configuration of their service on specific phones they provide that they can't do or provide correctly themselves.  After all they are a multi billion dollar company who can afford to rather than the time many customers spend trying to get these feature to work.

Thanks again.

Mike.

View more options