main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Android

Wifi Calling Switching When Not Needed

Highlighted
2: Seeker

How do I make it so that Wi-Fi calling is ALWAYS on when I'm at home, but when I'm not at home, it switches to cellular calling?

View more options
4 REPLIES 4
Highlighted
17: Community Champion

Hi @fr0stb1te 

 

I am sure this isn't something Vodafone would be able to do. WiFi calling is designed to kick in when there is no or limited mobile phone signal, if WiFi turned on you should find you are automatically connected to WiFi calling.

 

This thread from Android Central is asking the same question:  Automatically Switch to WiFi Calls when at Home? 

View more options
Highlighted
2: Seeker

My phone switches to Wi-Fi calling automatically, but I find that 30% of the time, it switches to cellular calling from Wi-Fi calling. My phone thinks the signal is good enough, which may be why it does this, but it really isn't. The signal is not good enough for me to be able to have a normal conversation. It also automatically hangs up when cellular calling tries to switch back to Wi-Fi calling and Wi-Fi calling doesn't always activate, even when I've set it to be on in my settings.  This happens quite often and is very frustrating. Any answers?

View more options
Highlighted
17: Community Champion

Hi @fr0stb1te 

 

If you put the phone on offline (flight mode) this won't happen and you will be able to only use WiFi calling.

View more options
Highlighted
17: Community Champion

Hi @fr0stb1te  as @AnnS  has said, put the phone in flight mode then turn on WiFi, that will ensure WiFi calling is active all the time. You will receive WhatsApp/iMessage etc but won’t receive text messages though. 

View more options