main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

This is a locked archive and content on this page may no longer be up to date. These posts and threads have been archived for reference only.

Archive

Can I block incoming 08 numbers?

SOLVED
View solved solution
Highlighted
2: Seeker

If so how?  Don't fancy this new scam where getting a 'missed' call can generate hundreds of pounds of charges to a high rate number.

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Champion (Retired)

@PaulH2016 I've just had a look at my online account (PAYG). Under Manage services; Bars I have this

Capture3.JPG

which looks reasonably promising, although from the wording it may not block absolutely everything. You could try turning this on, until the present problem has definitely been dealt with.

View solution in original position

View more options
9 REPLIES 9
Highlighted
17: Community Champion

Hi

 

Does your phone have a call / text blocking facility ?

 

Vodafone also have the Premium Rate Sms bar 

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui 2.1  / Android 10.

 

Samsung Gear s3 Frontier Watch.

Samsung Galaxy Buds.

View more options
Highlighted
17: Community Champion

Hi @PaulH2016

 

It is not possible to block or stop calls at network level.

 

If you are referring to the Vodafone announcement on the forum on the link below, Vodafone have identified the problem and are working with Ofcom and other network operators.

 

Unsolicited call charges

 

If it is an unknown number, you will not be charged when answering a call, you will only be charged for making a call.  Any genuine caller will always leave a message.  The rule is unless you know the number,  not to return the call. 

 

Fortunately, as you are PAYG, unless you had hundreds of GB£ credit, any scammer would only be able to take the available credit.  

 

 

View more options
Highlighted
2: Seeker

Thanks but according to a cousin EE can and have blocked calls from 08 and 09 numbers to his mobile.

 

Also regarding the Vodaphone message, media reports (I know, I know) say that it is happening to people who DIDN'T call the number back, including some who say they weren't even aware of a missed call.  Even if they did call it back, who is going to hang on for 12 or even 3 hours?  No one, so if a brief call-back only to find out it is some ambulance chaser in Canada still generates a call apparently lasting several hours, then Vodaphone's systems HAVE been compromised.

 

Personally I never respond to missed calls unless it comes up as being from someone in my address book.  Doing otherwise is just stupid.

 

Apparently on my phone I can download an app to block calls from withheld numbers ... but of course these are not withheld numbers.

View more options
Highlighted
17: Community Champion

Hi @PaulH2016

 

I guess you are referring to the International and Premium Rate Calling Restriction bar.  This will stop you making any premium rate calls to 09 numbers.

 

08 numbers are for special services calls and are not premium rate. You can find the charges for calling 08 numbers on the link below.

 

Vodafone PAYG Call Charges

 

No network can stop incoming calls to your phone, but it unlikely you will receive calls from any 09 premium rate numbers.

 

If you are concerned about any charges on your PAYG account, please use Live Chat for account access.

View more options
Highlighted
Community Champion (Retired)

@PaulH2016 I've just had a look at my online account (PAYG). Under Manage services; Bars I have this

Capture3.JPG

which looks reasonably promising, although from the wording it may not block absolutely everything. You could try turning this on, until the present problem has definitely been dealt with.

View solution in original position

View more options
Highlighted
Community Champion (Retired)

A friend having been hit by the above-mentioned scam has rather spooked me, so I decided to turn on the 'Premium rate information call and text bar - incoming only', as my balance is much higher than usual in preparation for a trip to Canada, but my account tells me I'm not eligible!

Capture4.JPG

Maybe this isn't available to PAYG, or maybe it's something that has to be applied by CS, but I settled for the outgoing version, which I could select online, and which I hope would block charges if the scammers chanced on my number.

View more options
Highlighted
2: Seeker

Like Annie_N I tried to set this bar - but I'm confused.  The bar is shown as being On, but the top of the screen gives the same problem message.

 

So I logged out ... and the screen gets stuck with 'Loading ...' and the broken circle.  But logging in via another browser page shows that bar as Off, so I guess I'm not eleigible either.

View more options
Highlighted
Community Champion (Retired)

@PaulH2016 The bars can be a bit confusing at the best of times or at least need to be made clearer.

 

I needed to respond to a sms from my bank last week but got "Content control is on" it wasn't, so on speaking to CS I was told to turn it on you have to turn it off and then turn it back on! Same with Premium rate texts. Turning the bars on and off did result in a confirmation text that the action had been completed.

 

It appears that on some bars (according to CS) when it shows as off it is on and when it shows on it is off.

 

View more options
Highlighted
Community Champion (Retired)

When I opted for the bar on outgoing premium numbers, the Off changed to On immediately, but I think that is more of an acknowledgement than an absolute, as the message at the top said that I'd be notified once the bar was in place - and I got a text confirming it some minutes later, also an email confirmation that it had been activated.

Like @PaulH2016, when I logged in later, the incoming bar had reverted to Off, but the outgoing bar was showing as On after I had received the messages. So I'd suggest going for the outgoing bar online, and possibly calling CS to see if they can activate the incoming bar.

View more options