main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Broadband connection

Constant broadband disconnections & reconnections

VsUK1981
4: Newbie

Over the last few weeks. I've been experiencing broadband drops. It's happening 3 or 4 times a day randomly & it's causing so many problems with my CCTV & watching Netflix & alike, that likes to kick you back to the main screen if you experience any network issues.  I have also noticed a drop in my speed as well around the same time this started. I was getting 71Mb download 18Mb upload without fail. Now I'm getting 67Mb download & only 12Mb upload. The download I can live with, the upload has dropped significantly. 

Also.. I'm getting this error in my routers log every time it disconnects & reconnects

08/05/2021	00:59:19	[45208.013827] DROP wan in: IN=pppoe-wan OUT= MAC= src=45.143.200.102 DST=(MY IP) LEN=40 TOS=0x00 PREC=0x00 TTL=246 ID=10121 PROTO=TCP SPT=56843 DPT=7846 WINDOW=1024 RES=0x00 SYN URGP=0 MARK=0x8000000	firewall
08/05/2021	00:59:16	Failed to send RS (Permission denied)	system
08/05/2021	00:59:12	Failed to send DHCPV6 message to ff02::1:2 (Permission denied)	system
08/05/2021	00:59:12	Failed to send RS (Permission denied)	system
08/05/2021	00:59:11	[45199.976327] DROP wan in: IN=pppoe-wan OUT= MAC= src=52.95.117.89 DST=(MY IP) LEN=86 TOS=0x00 PREC=0x00 TTL=208 ID=1474 DF PROTO=TCP SPT=443 DPT=49228 WINDOW=1192 RES=0x00 ACK PSH URGP=0 MARK=0x8000000	firewall
08/05/2021	00:59:10	[45199.252117] DROP wan in: IN=pppoe-wan OUT= MAC= src=142.250.13.188 DST=(MY IP) LEN=76 TOS=0x00 PREC=0x00 TTL=62 ID=49357 PROTO=TCP SPT=5228 DPT=47940 WINDOW=265 RES=0x00 ACK PSH URGP=0 MARK=0x8000000	firewall
08/05/2021	00:59:08	Failed to send RS (Permission denied)	system
08/05/2021	00:59:07	Failed to send DHCPV6 message to ff02::1:2 (Permission denied)	system

So if anyone knows what's going on & if it's just a setting I can change to fix, that would be great. Because I'm honestly sick of calling Vodafone, only to get someone who's clearly reading from a script & simply refuses to address the problem until he or she has ticked all the boxes. It's tiresome & it really fricks me off.

Thanks in advance!

View more options
6 REPLIES 6
Cynric
12: Established

VF do not have IP v6 facilities so ignore the DHCPV6 lines.

The DROP lines look like unsolicited Inbound packets that the firewall is blocking:

45.143.200.102 appears to originate from Belarus, but the other two are Google and Amazon (or at least that's what WhoIs says).

But there isn't any disconnect from VF in the log portion that you have shared, just firewall entries.

View more options
VsUK1981
4: Newbie

Yeah, I used https://www.abuseipdb.com/ to check the inbound IP's & some have been reported as being very abusive IPs from the likes of America, Russia & Like you've said, Belarus. The firewall is blocking, so it's doing it's job really. But every time this happens, my connection drops out & then re establishes itself a minute later. But the link is also dropped in the log, 8021q 'eth2_guest' link is down wan. I just didn't include it, I just included the red writing which was of concern. But every time I get a bunch if blocked inbound attacks, which is what they are really, my router drops the connection. Now I understand its a good thing for security, if in doubt, drop the connection. But its really annoying & causing me problems when I'm in the middle of things.

 

 

View more options
Jayach
16: Advanced member

There is no way dropped inbound packets should cause the router to reconnect.

Any reconnects should be being recorded by the router as "number of cuts". can you post your stats from the router like this:

DSL Status Information
DSL Mode
ITU-T G.993.2_Annex_B (VDSL2)
DSL Uptime
10 days, 15 hours, 3 minutes and 35 seconds
Line Coding
DMT
Status
Connected
Number of Cuts
0
Link Power State
L0
Line Quality
Downstream Upstream
Current Rate 76913 kbps 20000 kbps
Maximum Rate 79060 kbps 29081 kbps
Signal-to-Noise Ratio 6.3 dB 11.6 dB
Attenuation DS1 9.2 dB, DS2 22.6 dB, DS3 35.2 dB US0 2.1 dB, US1 15.5 dB, US2 25.3 dB
Power 12.7 dBm 5.2 dBm
CRC Errors in last 15303 minute(s) 2 2127
K (number of bytes in DMT frame) 0 0
R (number of bytes in RS code word) 10 0
S (RS code word size in DMT frame) 0.1010 0.3819
D (interleaver depth) 8 1
Delay 0 ms 0 ms
View more options
VsUK1981
4: Newbie

Hi, here's the info. Just to note. I manually restarted the router last night. I have also noticed, when I click on check for firmware update. It fails to update.

DSL Status Information

DSL Mode - ITU-T G.993.2_Annex_B (VDSL2)
DSL Uptime -5 hours, 1 minute and 55 seconds
Line Coding - DMT
Status - Connected
Number of Cuts - 4
Link Power State - L0

Line Quality

  Downstream Upstream
Current Rate67309 kbps11993 kbps
Maximum Rate68865 kbps18489 kbps
Signal-to-Noise Ratio6.3 dB6.2 dB
AttenuationDS1 4.4 dB, DS2 11.5 dB, DS3 19.2 dBUS0 2.3 dB, US1 8.5 dB, US2 14.2 dB
Power12.8 dBm-4 dBm
CRC Errors in last 301 minute(s)185284
K (number of bytes in DMT frame)00
R (number of bytes in RS code word)016
S (RS code word size in DMT frame)0.11350.0420
D (interleaver depth)1381
Delay0 ms4 ms
  Downstream Upstream
Super Frames100968913256694
Super Frame Errors113
RS Words01725488516
RS Correctable Errors05646
RS Uncorrectable Errors00
  Downstream Upstream
HEC Errors108670
OCD Errors00
LCD Errors00
Total Cells23449642230
Data Cells756205230
Bit Errors00
  Downstream Upstream
Total ES8450740
Total SES3012320
Total UAS14328311
View more options
Jayach
16: Advanced member

@VsUK1981 wrote:

Hi, here's the info. Just to note. I manually restarted the router last night. I have also noticed, when I click on check for firmware update. It fails to update.

 

I wouldn't worry about the firmware update failing, they all do that. It should update itself if needed.

The latest firmwares, as far as I can discern, are 19.2.0307-3261013 and 19.2.0307-3261019. I suspect they may be slightly different hardwares.

4 cuts in 5 hours is dreadful. You need to connect the router to the test socket and if the cuts continue call Vodafone on 08080 034 515, they will need to do some tests.

If your firmware is significantly older it may be the router is trying to update itself and failing, there have been instances of that on the forum in the past.

Do let us know how you get on.

View more options
Jayach
16: Advanced member

Also looking at the stats further, there seems to be something odd with the upload. I would have expected a higher upload on a 67Mbs download. The interleave is also very high, and although I don't fully understand what the power figures indicate, a negative figure doesn't seem right. When/if you try it in the test socket, repost the stats you get in there.

View more options