Showing results for 
Search instead for 
Did you mean: 






Fire Stick getting no internet connection

2: Seeker
2: Seeker

Hi, as of today, my fire stick is not connecting to our home broadband. This has been working fine since I had the broadband installed over a year ago. Today it is saying that it is connected to the WiFi with good signal strength and “channel 11 quality” however there is no internet connection 


I have connected the stick to the internet via my phone becoming a hotspot but I am getting nothing on my home broadband - this tells me that the stick itself is fine 


I can see the stick in my Vodafone broadband app also 


I’m having exactly the same issue and I’ve been back and fourth to Vodafone. I’m a new customer and before on Sky - no issues. They tried to upsell me to a booster add-on. I moved all of my furniture and got the tv closer to the router, about 1m with nothing in between. It’s still buffering but a bit better. I took Alexa echo and two iPhones off wifi to get that though.  Im superfast 1 too. Tearing my hair out it’s A fffffin nightmare ….

16: Advanced member
16: Advanced member

Have you tried resetting the Firestick to factory default and starting again?

2: Seeker
2: Seeker

Very similar to my Amazon fire tablet over my vodaphone broadband, "Connected, no internet" it says.

However I can see internet pages and download Kindle books.

But it wont download apps.

Works fine of my phone hotspot,

Any ideas gratefully received.  

Hi @gdevoy, thanks for your post. Has your device ever been able to connect using the Vodafone broadband? On the Amazon support pages, there is a section named 'Can't connect your Fire TV device to Wi-Fi', have seen this page and attempted the steps? 🙂


 I have been through a lot of this, rebooting the router and shutting everything down and starting again. To no positive effect.


My own current predudice is that, while the Amazon tablet is still relatively new (18 months old) it really, really needs a very strong wi-fi signal to work propertly and the vodafone router signal, although only about a year old is really starting to weaken. My Samsung Galaxy tablet is showing low vodafone router power combared to next doors Sky system but still hangs on. The only failures are with the Amazon tablet.

I have now done some further research and there seems to be a thread from 2017 identifing a particular issue between Vodafone routers and Amazon devices. 


All my other devices work fine with the router and my Amazon device works fine thethered to my mobile phone.


Dissapointingly this thread I found offered no solutions that did not involve tinkering with the router settings and I am not going there. Further dissapointingly the 2017 thread had been closed without resolution. It sounded like it needed corporate action from Vodafone or Amazon to make changes to their default setup and there were too few users affected to make it worth their while. 

As I said in an earlier post, the resolution for me was whatever was carried out remotely during a chat session, for comparison my firmware version is 19.4.0551-3261103.  If you're on an earlier version it might be worth contacting vodafone to hopefully get an upgrade. 

The issues with the firestick & Roku have reappeared a couple of times, but a reboot (leaving the router off for 30+ seconds) has resolved it each time.

Well. [Removed] me. I rebooted the router following your instructions and the issue seems to have just disappeared.


I was confused by: 

a) The initial issue was lack of range and I thought introducing the extender was causing the problem.

b) Every other device in the house connected to the router and or the extender and worked fine.

c) The Amazon fire was displaying web pages even althought it said "connected / no internet". It just would not download apps or Kindle books.

d) I had re-booted the router before and it did not seem to help.


This time I powerd down the router, went and made some scrabled eggs (not that I think that is significant, then plugged it back in and everything seems to be working. Kindle now "connected". No mention of "no internet" and downloads seem to be fine. 


Many thinks for the encouragement to try again.



[MOD EDIT: This post has been edited to remove off topic/personal information/inappropriate content please see Community Guidelines]

Glad to hear it!


I had issues yesterday with my Wi-Fi dropping out and rebooted the router and Vodafone  extender. 

Now my Firestick says no internet even though every other device works perfectly. 

I have run out of ideas on what to try next.