Showing results for 
Search instead for 
Did you mean: 






TP Link Archer 2800 as router

3: Seeker
3: Seeker

Hi folks,

Ive been trying for most of the day to have my router TP Link 2800 connect to Vodafone instead of the THG3000

I've got my username and password and the settings from Vodafone but regardless of what I do it won't connect.

I had tried most of the settings Vodafone included in their text but have since read on here you don't have to change much if anything at all.

I had been messing about with VLAN, Authentication type and MTU then as I've said noticed a lot of forum posts stating, turn VLAN off and it should work but hasn't for me.

I'm on FTTP 910Mbps which I believe is via Openreach as I get 109Mbps upload.

So changing the username and password only on my TP Link 2800 doesn't connect me.

Anyone using this router or have any other suggestions?

I'm about to ask again for my username and password to make sure I've been given the correct details.



3: Seeker
3: Seeker

Hi, correct me if I am wrong but the only tp-link 2800 routers I can find are compatible  with VDSL2, ADSL2+, ADSL2 and ADSL so not suitable for use with an Openreach FTTP connection. A router with a Gigabit WAN port is needed. I use a tp-link AX53 which recognises the connection and asks for your username and password and then takes a few seconds to negotiate the connection.

3: Seeker
3: Seeker

@pwilliment thanks, that was the first thing I thought of when it wouldn't work so wasn't sure although it does have a LAN/WAN port so I was hopeful.

I had a better search of the internet this morning and came across a similar question.

The solution that worked for me was:

Using the Tether app login to Router and select Tools
Go to Operation mode and change to Wireless Router.
The router will then reboot.
Go back into Tools and Internet Connection, change the connection type to PPPoE
Enter Username and Password 

Hope it helps someone else.

Hello P3asa - I have a TP link router, the AC2100, not sure if theres many differences they look the same but assume mine is inferior to yours, but like you I am trying to swap from the awful THG3000.


However on both my phone and via a laptop I have tried doing exactly as you did, first changing to wireless router (is this because the ONT on the wall coming into my property is a modem)?

However I enable the VLAN, however I am unsure what the VLAN ID is?  I just put "1" but as the internet light stayed red and it was saying no internet, I am assuming this was clearly wrong?

Hi Alex,

Connect the ONT to the LAN/WAN port on your AC2100 which should be in router mode. Go into Tools and Internet Connection change to connection type to PPPoE and enter the username and password that Vodafone gave you. Make sure you are not confusing O and 0 or 1 and l. With fttp you don't need to enable the VLAN or enter a VLAN ID or anything else. It should just connect after a minute or two.

Thanks very much for the reply, I had no idea the VLAN needed to be left off

This is of interest to me because I am about to be upgraded to Fibre and I have the TP-Link AC2800

Vodafone gave me the username and password to login to ADSL a couple of years ago and it's been working fine.

When I have a Fibre Modem will the username and password be the same please?




16: Advanced member
16: Advanced member

Upgrades are classed as new services. New service=new login details.

Get your FTTP up and running with the Vodafone router, then contact CS on the link below for your PPPoE login details. You can then set your TP-Link up. 

Thanks for the info, I'll use the Vodafone router on the install day and then swap to the TP-Link afterwards.

I presume they automatically program their router with a new username and password when it's first attached to the fibre, Just like when you get a new router through the post.



3: Seeker
3: Seeker

That is great, glad it is all working for you