Showing results for 
Search instead for 
Did you mean: 






Vodafone Wi-Fi hub / router (THG3000) issues

2: Seeker
2: Seeker


I'm having issues which seem to be related to the Vodafone Wi-Fi hub / router (THG3000) and wondered if anyone has experienced anything similar. I've been using VF fttc broadband since May and keep having issues which seem to be related to the router / hub.

Line speed seems excellent and is fairly constant @ 80Mbs down 14Mbs up but I have an issue with an unstable internet connection, every so often (worst case every 2 or 3 minutes) devices connected on wi-fi will show connected but no internet errors and wired connections come up with internet unavailable or unable to obtain IP address. If I try to get on to the router to see what’s going on I can't connect ( won't connect and the VF app tells me the router is off line) and even though the lights are white all of the buttons on the router are inactive (WIFI, WPS and even the reset button don't work) so the router appears to be hung but is managing to hold up the outbound connection and intermittently work for clients. Powering off/on the router brings everything back to normal for a few hours or even days but eventually we go back to the same state.

To me everything points at a router problem, the line was on test last week and showed no errors and the speed isn't being pegged back, unfortunately I can't get onto the router when there's a problem to see if there is anything in the router logs.

BUT I'm now on my fourth router, the first one lasted for a month before this issue came up, the next one worked for three months until the same issue occurred, number 3 lasted a month and its replacement (the current router) had an issue from day one. 

Is there an issue with these routers and I've been really unlucky to get 4 faulty ones or can anybody think of another problem? I'm pointed towards the router because I get the issue on wired and Wi-Fi connections (and two different Wi-Fi systems, I normally use a mesh to give whole house coverage and only turn on the Vodafone Wi-Fi for trouble shooting / elimination) and on the other side the line itself has been tested and is consistently 80Mbps. Plus in the past replacing the router has made the fault go away, at least in the short term.

Current work around is to turn the router off/on when I make my early morning cup of tea and it might last the day but that's not really a fix. I'm loathed to put my own router in to fix a Vodafone issue but if I do buy one does anybody have any recommendations?


Thanks in advance


16: Advanced member
16: Advanced member

I find it unlikely you have had 4 faulty routers from Vodafone, especially as they all seem to have the same fault. My THG3000 has worked well well and although it did have a tendency to "lock up" in the early days whilst I was investigating/changing it's settings it seems a good workhorse if it's left alone.

You speeds seems suspicious as to get full download but quite reduced upload doesn't seem right. Have you had Openreach out to test the line? I can't imagine any normal ISP sending out 3 replacement routers without getting the line checked.

Getting your own DSL router for testing seems a good idea and as you use a mesh for your WiFi you will only need a reasonably cheap router. One of the low priced TP-links should do.

Do let us know how you get on.

Thanks for that Jayach, I'll go cheap or might even look at reusing one of the routers I'm left with after changing contracts. The line was monitored for a week with no errors so it might be difficult to get an Openreach engineer to come out to have a look, as for the upload speed I'm not too worried about it, it's pretty constant and I think you'd be lucky to get 20Mbps upload out of an FTTC service so I'm not far off.  

Time to rummage in the loft to see what routers I can find

16: Advanced member
16: Advanced member

You will need to get a router that you can add your Vodaphone credentials to. You will need to get them from Vodafone.

I was originally put on a faulty fibre port which caused no end of problems (random reboots and fluctuating speeds and SNR levels.) It took 3 months and 2 Openreach visits but my line is now solid at 79.3 down and 20 up. It also has an SNR of 12.3 on the upload so is capable of much more but I'm not contracted for it.

Jayach did you get this sorted in the end?


I have a very similar problem to yours, with the router going totally unresponsive, if I am lucky to not be disconnected, I am unable to get into 192.168. If I am disconnected, I can't get an ip assigned to me to get back on the network.


Turning it off and on totally remedies this, but surely this shouldn't be happening at all. 

16: Advanced member
16: Advanced member
@Suzuki80 Yes since my line problems were sorted my router has been behaving itself. I'm often making changes whilst checking things to answer queries on here and it has not locked up once recently.
It really was only in the early days, I don't think it's a bad router for an ISP supplied device. Just needs the firmware improved.

1: Seeker

hi, I’m a new customer of their s. 12 years with sky no issues with my router/broadband. Now I have WiFi streaming and connectivity issues. All my ctv units no longer steam with a poor WiFi connection plus lost WiFi to printer upstairs . I’ve tried reconnection with the devices. Gone through the usual Vodafone checks. All seems ok up to the router. Devices work if sat next to the router. Although a little buffering from our Ethernet connected smart tv. It’s the router that’s the problem. 

3: Seeker
3: Seeker

If it's any consolation (I doubt it is), I've been experiencing the same issues in the last couple of months.

16: Advanced member
16: Advanced member

I agree with jayach the router seems rock solid ( mine has been rock solid for about 18 months and it handles a lot more devices connected to it than i thought it would )

but now I have also started having the issue with the router being unresponsive and the only thing you can do is turn it off and back on  

I have also started seeing this issue on other forums with the Vodafone router being unresponsive. 


my best guess would be a router firmware update or the router is doing overtime for some reason

the only thing I have found in my router logs is this, (but I don't think its enough to crash the router or maybe it is)


edit Today I can't connect to 5G wifi and I get a router screen telling me the internet is down and to please plug in your mobile stick . The joke is the Internet is up and running 2G wifi is working fine and ethernet is also up and running.





13: Advanced Member

The only issue I've started to have in the last 3 months is that the router eventually refuses to allow my kitchen internet radio to connect to it in the morning. I then have to reboot the router to allow things to work again.

I suspect it's a firmware issue.

This happens after about a month's uptime. 

Apart from that, it does the job.