Showing results for 
Search instead for 
Did you mean: 






139:NFErr_MC_AuthFailure when using Netflix Apple TV

3: Seeker
3: Seeker



I have only had my Vodafone 5G GigaCube for 4 weeks -- and I have had problems with streaming from Netflix on the Apple TV device.  This problem doesn't appear on any other device or any other app or website.  This problems is specifically restricted to the 5G GigaCube when using Apple TV to stream from Netflix.


My friend who is on the O2 network -- created a wifi hotspot on her mobile phone -- and when I connected my Apple TV to her wifi hotspot then Netflix streaming would work on the Apple TV.  When I reverted back to my GigaCube 5G it stopped working.  So this is 100% a problem with the 5G network.


There are many people who have posted similar problems -- but there has been no serious attempt to resolve this issue.  This is quite a serious matter -- as its reason for me to throw the Router in the bin.


The same issue has been posted several times here:


Other forum members (1st link) are speculating that it appears to be a problem with Vodafone blocking some specific certificate servers used by Netflix (which are specific to Apple TV devices).


No amount of switching off the device, removing the plug, switching off the router, restarting the router, plugging the AppleTV back and reconnecting to the 5G network is going to work.  So please don't give me bs answers.  The fact I could get it working on a different network means I expect Vodafone to address this problem directly with Apple.


I will not allow this issue to go until Vodafone acknowledges this is a problem with their network and I will be raising a customer complaint unless a resolution is found.


If others have similar problems -- please add a reply here so we don't let this problem get closed without a resolution.






Moderator (Retired)
Moderator (Retired)

@SureshK How long have you been unable to connect for? Has this always been the case, since you bought the GigaCube? 

Hello Jerome,


The problem first happened a few days after I got the GigaCube, which was a month back -- I then spoke to the technical support and they did something in the backend - something related to content restrictions. 


And the problem resolved and I was able to stream Netflix on the Apple TV.


Then 2 weeks ago -- the problem has come back again. When I spoke to technical support they said that the restrictions are still the same.  I think the solution to solve it the first time would have unblocked some certain servers.


This time around -- I am requesting the technical support team in Vodafone to speak with Netflix and properly debug why the TV streams are not accessible from Vodafone.  Like I mentioned earlier, I established a mobile hotspot on the O2 network -- and it was able to stream.


I also spoke with Netlix and they said to ensure that the following servers can be resolved:


They also said that once that has been proven to work they would discuss further with certificate servers.


I really hope Vodafone can speak with Netflix and resolve this problem



Moderator (Retired)
Moderator (Retired)

@SureshK I don't think contacting Netflix is going to fix this, as it's not an issue consistent with all customers/Apple TV users with GigaCube. So I can understand more around this, are you facing the same issue when you try to stream Netflix on your phone or any other devices connected to the GigaCube? 

if its clear what the "139:NFErr_MC_AuthFailure" error means and we are sure its not a DNS or certificate server problem then I guess there is no need to speak with Netflix.


Back to your other question, the problem doesn't arise when I stream Netflix on my iPhone/iPad/MacBook.  Its quite puzzling that it has been working fine on my Sky Broadband for the last 3 years and also now when I switch to my friends O2 mobile 4G hotspot.


Could it be something blocking the CDN servers which are used for streaming files on TV/4K vs regular mobile devices screens?  

Community Manager
Community Manager

I think we're going to need to take a closer look into this @SureshK. As we may need access to your account to follow all avenues that could cause this, pop us a message through on of our social channels with a link to this thread and we'll be happy to take a look and get everything sorted for you 😊

@Sureshk , I have exactly the same problem. Have you got to the bottom of it?

I have data only sim Unlimited Max which I only got today, in Huawei B535 Mobile Router. Net flix plays on other devices but not on Apple tv. I am still connected to BT broadband and Netflix plays fine on that connection.

Going through this forum, I can see this has been going on for a few years. Not impressed at all. Please fix this.

Hi Akato

No I have not got to the bottom of the problem -- its clearly something with their network, since it worked fine for 3-years with my Sky Broadband.  And when I created a wifi hotspot on the O2 network it works fine even now.


So its a network problem with Vodafone -- but no one in technical support is taking ownership or competent to address it.


My suggestion is to raise a customer complaint.  This is simply not acceptable and dont expect any help from the moderators as they'll tell you sent a message on social media...  This link shows how bad the customer service is with Vodafone, the worst in the industry.


TrustPilot also shows the same thing:


Vodafone's customer service team is on 033 33 040 441.


Moderator (Retired)
Moderator (Retired)

Hey @SureshK 

Just as @Mark advised, we're going to need to take a closer look into this. So that we can do this and take a look at your account, please contact us on Social Media here

Let us know how you get on! 

Well Josh -- if you are saying other gigacube users are not having problems with using Netflix on Apple TV then it must be a network problem specific with the my local mast.  Can you confirm that -- because this ticket has been open with customer complains and technical support for the last 2-months and they have done f*** all about it.