Showing results for 
Search instead for 
Did you mean: 






Help Activating a Data Only SIM

2: Seeker
2: Seeker

Hi. I'd like some help please, I've had the worst experience trying to get this SIM activated today.

Bit long winded but this is what I've been through so far -


I bought a TP Link Archer 200 router from Amazon and ordered a  Vodafone Data Only SIM + £25 of credit
They both arrived, I inserted the SIM into MiFi router - Internet is listed as up but can't get a connection on laptop
Can see external facing IP address, router has configured itself for Vodafone, can see DNS servers allocated
Can see traffic flowing up and down on the router admin interface, no devices attached to it can access the internet

Wondered if I needed to register the device to make it work. I went to register SIM on vodafone website by following the link in the documentation for the SIM. Loaded and the documentaiton says  to click on "Register for my Vodafone" - this link doesn't exist. The URL just loaded a page asking me to login or make an account. Not a huge issue decided to make an account.

The next page asks me to register a device (which I don't have, I bought mine from Amazon) or provide broadband order number (which it doesn't accept).

There is no option presented to register a SIM nor is SIM mentioned anywhere on the sign up page. At that point I decided to try the "broadband" option as it's a data only sim, so, mobile broadband but I'm stuck at this point now, can't get back, can't proceed. It asks me for an order number, which I provided, but it won't accept it. Invalid.

I decided at that point I wanted to go back and try the previous page, but the way of the site has been coded, this no longer presents as an option and I'm stuck on the page stating my order number isn't valid. At this point I got annoyed and decided to clear the history of my browser for the last hour and have another go by selecting the "device" option that doens't mention SIM.

It asks me for my phone number which I notice is on my documentation.
Put the phone number into the box, confirm and get back a security code prompt - "Your code has been sent to *******2909". It's a Data Only Sim in MiFi box. Useful.


Stuck at this point, so ring the 0808 listed helpline. I hit the initial menu and ask for customer service, and then technical help. The sub menu after that is useless. All of the categories don't match what I need help with so I sit there unsure of what to press for a couple of solid minutes whilst the pre-recorded voice patronises me for not putting anything in.

I spend another 5 solid minutes in the automated system, finally find an option to talk to someone after the menus go through about 8 entire times. Placed in a queue. Stuck in queue. Got bored. Hung up after 20 minutes


Then I managed to get into the advanced admin interface on the MiFi router, found the message and security code. This required me flipping back and forth on WiFi interfaces on my laptop.
Used code to activate my account - internet still not working on MiFi device even though it reports as up.


Maybe I'm missing something or doing this wrong. I checked the documentation sent with the SIM but it doesn't mention needing to do anything to active the SIM at all. Just plug it in and go. I decide to search online for how to "activate my SIM" just in case. Found a page listing lots of different circumstances, it says to click the item that is "right for me".


Found a circumstance where it asks if I wanted to activate a SIM, yup, try and press that option.

Nothing happens. Inf act, on mobile (iphone, Chrome browser), none of the items work when pressed on, they exist on the page but they aren't links. The page does nothing, the phone simply zooms into the text if you tap the options.


So again, totally useless.


I log back into the Vodafone internet dashboard of the user system and find the little bot at the corner of the admin panel.  It states "let me know if you need any help!" I do, thought I would give it a go. However when I clicked on it, nothing happens, at all. The text just highlights, it's not a box that actually accepts any input.

Also my credit on the dashboard  has now changed to "sorry we can't get this data right now".


I'm 2 hours down, I still have no working internet, none of the Vodafone resources do anything useful and none of the marketing/help material matches what is online. This is literally one of the worst setup experiences I've had in my entire working life.


I'm testing this to arrange a contract for a fleet of MiFi devices for a large mobile deployment and right now there is currently 0% chance I'm going with Vodafone. My users won't have a chance in hell of getting anything working.


17: Community Champion
17: Community Champion

Hi @D1m3b4g 


You need to convert the credit to a data pack.  See here: Topping up your mobile broadband .  When you have the data pack the SIM will activate when it makes a connection to the network, when activated you will be able to set up the online account.

Further information for you with the APN settings you need to instal here: Getting Started 


Before registering again clear cookies and cache on your PC.


So firstly - thank you for the message, genuinely useful as I may be able to get going now, but that is literally ridiculous.


There is NOTHING in the documentation, physical or otherwise that explains I need to convert the credit to a service after installing the SIM. It's cost me getting on for 3 hours of my time.


I paid for a specific package, £25 for x amount of GB for 90 days when I signed up. Why would I (or anyone) assume they would need to "Top Up" again after pre-paying?


Also in classic Vodafone fashion the instructions on the site you've provided yet again don't match what is seen on the actual website. The link doesn't say "Top up now" and consistently the admin panel keeps stating "Sorry we can't get this data right now" removing the actual link to Top Up completely.





This whole process has been a complete shambles.

Thanks for your feedback @D1m3b4g and we're sorry that the activation process of your mobile broadband service has not been straight forward. The feedback is something that we'll get passed back our teams here at Vodafone, if you're still not up and running, please drop us a message on Twitter or Facebook.