Showing results for 
Search instead for 
Did you mean: 






R212 Firmware Upgrade

2: Seeker
2: Seeker



Could someone please tell me where I can get the firmware upgrade for the R212.  I bought an R212 a couple of days ago to replace an old 3G MiFi that I had as we now have 4G coverage in our area.  While I get good download speeds of 30Mbs from 3 out of 5 bars on 4G, surfing the web is painfully slow as the browser (Chrome) constantly says Resolving Host... which I assume means it is doing a DNS lookup.  My diagnostics are:


Product nameR212-Z
Software VersionBD_R212V3.1
Web UI Version2.008.5513
Hardware VersionVer.B(T3)


I am hoping the 3.5 firmware upgrade will help resolve this.  Could someone please let me know where I can download this from and how to install it.




You need to factory reset the device, then it wil see it. I had the same problem :Smiling:

View solution in original position

218 REPLIES 218

Thanks John, worked first time once reset.






I'm running software BD_R212V3.4 and having issues with the SSID disappearing when no users have connected overnight.  I either need to press the button on the front of the device or turn it off and back on again in order for the SSID to re-appear.


Can someone please send me the V3.5 firmware to upgrade and see if it resolves this issue ?

Hi MobileGuy,


I've requested that this is sent out to you.


Please follow the instructions carefully.





Hi Ian,


Thanks for the reponse and for sending me the file.


However, no matter what I've tried, I cannot get the device to be detected by the firmware upgrade software.  I've tried on two seperate laptops, one running Windows 7, the other running Windows 8.1.  I've tried two seperate USB cables.  I've installed both the Vodafone Mobile WiFi and Vodafone Mobile Broadband software.  Running the firmware updater returns "No device found - Updater cannot find any devices".


Within device manager, I can see under universal serial bus controllers "Vodafone Mobile Broadband Bus Enumerate Device (Huawei)" & "Mobile Broadband Controller" so the device appears to be detected by the laptops.  By the way, I have four of these devices and none of them are detected by the firmware upgrade software.


On the diagnostics page, I'm seeing the following information for my device.


Product nameR212
Software VersionBD_R212V3.4
Web UI Version2.008.5513
Hardware Version



Any idea why I cannot see any of the devices ?




You need to factory reset the device, then it wil see it. I had the same problem :Smiling:

Hi garethdenzil,


Thanks for the update mate, restoring back to default worked....bizzare you have to do that, but at least it's working now. 


Cheers !

where i can get r212 firmware

Can you please send me a copy of the firmware ?



Community Manager
Community Manager

@Robdcumming - I've emailed you a copy of the firmware. :smileyhappy:

The attachment will expire on 18 August 2017. 

Hi Could somebody send me the link to the firmware update for the R212