Showing results for 
Search instead for 
Did you mean: 






Adding an Extender

2: Seeker
2: Seeker

Hoping somebody can help.  Just recently switched to Vodafone Broadband and all devices have been accepted onto the network with the exception of my TP-Link Extender (no lan plug access so just wifi connection).


This worked fine with my previous provider and my laptop was able to connect without any problem.  Now what is happening is that I can see the extender in the network list, so I know it has paired with the main router but when I try to connect I need to enter the Wifi password, which when |I do it advises me that the network key is incorrect.


I've tried both the wifi password, the network hub password and the MAC number on the extender itself (because I saw a diagram on one site saying that was the password - it doesn't seem to be).  


Has Vodafone blocked extenders on their broadband?


16: Advanced member
16: Advanced member

Slightly confused...


Can you see the extender in the list of connected devices when you use the VF router's web-admin page?

It would also help to know what the device model number is:  Some TP-Link extenders are pure extenders, others use both bands with one band used only for backhaul to the router.


If it's not working at the moment then you probably have nothing to lose by performing a hardware reset on the extender and setting it back up using the TP-Link extender app, or WPS (which once set up I'd turn off on the router for security purposes).  With extenders, it's often important to follow the instructions like a complete pedant!

I'm slightly confused by your questions, don't know much about the techie stuff (VF router's web-admin page), I just added the extender and it arrived in the network list, ready to choose, which was how I set it up for the previous provider.

Model is 300 Mbps Wi-fi Range Extender

Model TL-WA85-4RE

Default SSID - TP-Link_Extender

S/N Model TL-WA854RE(UK) Ver 4.0

and there is  MAC number beneath that.

I added it using the WPS button on the Vodafone router and then on the TP-Link Extender.

I also reset the extender using a pin in the space to do so.

16: Advanced member
16: Advanced member

If you've set up the range extender using the WPS button, then it'll share the same SSID name and password as the router SSID and password.  So you shouldn't need to change the settings on any devices in order to be able to connect to the range extender, they'll be the same as you have for the router.  If you want to change any settings on the range extender it's initial set up username: admin & password:admin (probably a good idea to change).

Thank you for replying, just what I thought however trying to connect to the extender network it just doesn't accept the same password which is why I asked whether Vodafone have blocked extenders.

I am having the same issue using that extender as yet unable to get it working 

Hey @raymondhalsall I hope you're well 🙂

If you've tried the troubleshooting that is in this thread and you still can't connect to your extender, please get in touch with our Broadband team on 191 free from a Vodafone Pay monthly mobile, or 03333 040 191 from any other UK phone (standard charges apply) or drop our Social Media team a message here and they will happily help you with this! 

I've set up two different extenders without any problems, so 3rd party extenders are certainly not blocked. However, I've always found that adding them using the WPS function unreliable, regardless of provider or router, so I always use the extender's web interface to connect to the router.


My advice would be to perform a factory reset on the extender, connect to the extender directly and set up manually via the extender's web interface - refer to the instructions supplied your particular extender.

16: Advanced member
16: Advanced member

*refer to the instructions like an absolute pedant!  No short cuts or thinking you know better :Winking_smiley:

Just to say that all of a sudden it decided to accept the password.

Referring to @raymondhalsall above, I did contact Vodaphone who didn't want to give any assistance in this matter, but they would happily have upgraded my package, at quite a large price increase.