main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Other broadband queries

No internet with Asus RT-AC68U router and Zyxel router in modem mode

SOLVED
View solved solution
Psychophile
2: Seeker

Hi all

I am trying to use my Asus RT-AC68U router on the Vodafone VDSL2 service, by connecting it via a Zyxel VMG3925 B10C router, set in bridge-modem mode.  I have been able to connect the Zyxel in Routing mode (using the PPPoE user name and password provided by Vodafone Support) to the Voda VDSL2 broadband and get full internet access through it.  With the Zyxel set to bridge-modem mode the RT-AC68U appears to connect to the WAN correctly, using the same PPPoE authentication.  Despite this I cannot access the internet from my PC or other devices connected to the Asus router (though the internal LAN works fine).

The network tools on the Asus successfully 'ping' external servers, so it seems there is a working WAN connection.  I am guessing that the internet access problem is something to do with DNS not working correctly between the Zyxel and Asus, but can't figure out what.  I initially left the Asus to pick up settings automatically from the ISP, including DNS servers.  When that didn't work I tried changing the DNS settings in the LAN page from automatic to fixed (using Google DNS 8.8.8.8) but this didn't help either. 

From reading previous posts on this forum, I know people have been able to get various Asus 'RT' routers working through third-party modems, so I'm obviously doing something wrong!  Any advice or suggestions would be most welcome.  

   

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
Psychophile
2: Seeker

I had another bash at this and eventually solved the problem.  The Windows network diagnostic wizard gave me a clue with a message saying that the 'default gateway could not be reached'.

For some reason I had entered the Zyxel router's default IP address (192.168.1.1) as the Default Gateway address in the Asus DHCP server configs.  But when the Zyxel is in bridge-modem mode it's IP address is not visible on the network, other than by a PC connected to it directly.  So I guess the Asus router was trying to route DNS traffic via this invisible gateway and getting nowhere.  After deleting the Default Gateway setting (and leaving it blank) internet access was restored!

View solution in original position

View more options
3 REPLIES 3
Jayach
16: Advanced member

You say you are able to ping from the Asus, but can you do so from devices connected to the Asus?

View more options
Psychophile
2: Seeker

I had another bash at this and eventually solved the problem.  The Windows network diagnostic wizard gave me a clue with a message saying that the 'default gateway could not be reached'.

For some reason I had entered the Zyxel router's default IP address (192.168.1.1) as the Default Gateway address in the Asus DHCP server configs.  But when the Zyxel is in bridge-modem mode it's IP address is not visible on the network, other than by a PC connected to it directly.  So I guess the Asus router was trying to route DNS traffic via this invisible gateway and getting nowhere.  After deleting the Default Gateway setting (and leaving it blank) internet access was restored!

View solution in original position

View more options
KeithAlger
16: Advanced member

At the very least you need to have the local IP of the modem different to the local IP of the router or it's going to cause routing issues. *Depending on the router firmware this may only show up if you attempt to access the modem web-admin.

So it would be common that if your local subnet for the LAN were 192.168.1.0/24 with the router as 192.168.1.1 then the modem would commonly be 192.168.2.1 or 192.168.5.1 with its own (/24) subnet.

 

*I'm aware that using the router console and the appropriate commands it is possible to direct a local IP to the WAN port but is faff and frankly less robust!

View more options