main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Pay as you go

Cannot connect to 4G services

Highlighted
3: Seeker

Hi everyone, I recently migrated from contract to PAYG. 4G worked perfectly on contract but now I'm locked onto H+ with terrible speeds. I've tried every combination of APN settings and spent an hour on online chat with an agent who assures me 4G is active on the account. I'm convinced it's not and speedtest app tells me it's still a 3G (H+) connection. My handset is a Samsung Galaxy S9 and was getting fantastic speeds on 4G before I 'downgraded' to prepaid. SIM, handset and geographic area remain exactly the same. Also to add, strangely, that pp.vodafone.co.uk doesn't work as an APN setting, only wap.vodafone.co.uk. I have the big value bundle with a generous data allowance (15 GB at the moment) but little use if I can't access the 4G network. Please help!

View more options
5 REPLIES 5
Highlighted
17: Community Champion

Hello @jb007za 

 

That maybe the issue as a person needs to use the pp.vodafone.co.uk Apn Setting.

Your still using the Pay Monthly Contract Apn Setting so either your account hasn't fully updated to now show as Payg on Vodafone's Systems or the Sim Card needs replacing.

 

How-to-manually-enter-vodafone-apn-settings. 

Perhaps try texting WEB to 40127 to see if that sets up the phone properly.

deviceguides.vodafone.co.uk 

It might be worth just checking in the phone's connection settings to ensure 4G / Lte is still activated.

Also if this was me I'd double check with customer services on 191 or the Vodafone Social Media Teams via Contact-us-for-account-specific-queries that 4G is definitely activated on my account.

To rule out the phone or Sim Card as a process of elimination try your sim card in another phone if you can.

See if you get 4G also when you commute away from home.

You can check your Vodafone masts via Status-checker. 

Sometimes if a sim card is glitching a Vodafone Highstreet Store can perform a Sim swap in house to replace it.

Take photo ID.

It's possible to move from contract to payg has caused this and you could do with another sim card.

 

🌈Stay Safe & Stay Alert.  🌈 

Current Phone > Samsung Note 20 5G - SM9860 Snapdragon.

Samsung One Ui 2.5  / Android 10.

View more options
Highlighted
3: Seeker

Thank you @BandofBrothers

Really interesting and I'm now more convinced the problem is a systems one.

I've tried the pp.vodafone.co.uk several times and it refuses to work. Two online chat sessions with agents. Both very helpful in getting me to re-enter settings but pp.vodafone.co.uk produces no data connectivity (only wap.vodafone.co.uk works and only on H+)

After exhausting the online support, I think I'll pop into a Vodafone store and request a SIM swap.

4G coverage in this area is excellent and everything used to work perfectly 2 weeks ago when I was on contract.

Just to add that LTE is definitely active on my phone (I've even toggled between 3G only and LTE/3G/2G just to check this), I've done numerous restarts, texted WEB to 40127 to get the latest settings, etc.

Grrrrrr....!

View more options
Highlighted
Moderator

Hey @jb007za, thank you for trying everything you have tried so far in regards to getting your 4G up and running!

It's a good shout to try a SIM swap - I would also take up @BandOfBrothers suggestion of trying your SIM in a different device just to rule out a device issue.

 

Feel free to drop us a message on social media for us to triple check your account 😊

Make sure to include a link to this thread and your account/mobile number!

 

View more options
Highlighted
3: Seeker

Thanks @Evie

I had anticipated a SIM swap but fortunately your fantastic colleague, Gem (Twitter support) was able to assist.

Essentially, it appears that something had gone wrong in changing over from contract to prepaid. As soon as the prepaid profile was reset, 4G connectivity was back. This meant taking everything off (credit, big value bundle and even starting again with my portal login) and starting again, however the problem got fixed. I'm now back to where I was before... with 4G! Very happy with the end result and grateful for everybody's assistance.

Cheers!

View more options
Highlighted
Moderator

Thanks so much for updating us @jb007za - glad to hear Gem was able to get things with your 4G sorted for you! I've passed on your thanks to her and our Social Media department 😁 You know where to find us if you ever need anything else in the future!

View more options