Showing results for 
Search instead for 
Did you mean: 






Connecting Apple watch to mobile network -headache!

2: Seeker
2: Seeker

Hi All, 


I was wondering if anyone has had the same problem as myself or know of a fix!


I signed up to Vodaphone sim only xtra plan and as usual given a temporary number whilst my other number is updated from voxi. 

Whilst this was processing I set up the sim in my phone and was able to connect my watch to my plan and subscribed to the one connect - all is good!


The next morning my number updated and was sent an email saying my one connect service would be temporary unavailable whilst my number updates and would be notified once done, sure enough within an hour i received that email with everything now all set up and back working.

I checked my watch and could see there was no plan under the sim and the status said no connection.


It has now been 10 days since this issue has started and i've spoken to around 15 agents over chat and two on the phone with absolutely no help whatsoever, below are the steps we have tried (on numberous occasions) to get it working;

1: unpaired/paired watch ( must have done this around 11 times)

2: Reset watch to factory settings

3: updated my E-ID number both myself via online account and to advisor on phone and over chat

4: Reset my network settings on both watch and phone (Multiple times)

5: cant tell you how many times I've waited 24 hours for back end issues to be updated and promised that all would be working by the next day.

6: went into a Vodafone store to speak to advisor and they had no clue what the issue could be!

7:  spoke to Apple tech support who screen shared my phone and went through all my settings to check everything - all is fine on my end with devices, he said that Vodafone aren't sending the ICCID number and info across .

8: I suggested to Vodafone to cancel my current one number subscription as this was created before my number was updated and now my number has moved across ok to then resubscribe - this has been done and the issue is still the same.


I'm now when I try to set up the mobile plan through the watch app i get the splash screen from vodafone saying 'oops there's been a server error'.

it wont even connect to the one connect website.


I login to my one connect account and can see that the subscription is active and the correct E-ID number is displayed.


I was promised that today it would be fixed but guess what still nothing and was due a phone back at 12:30 and still nothing  - not a great first impression of Vodafone,





Hi @kieron88j 👋 Firstly I would like to apologise for the issues you've been facing with the setup of your Apple watch. This is certainly something we can look at helping with, as this is something that will require account access could you please contact our social team by clicking here. We will then be able to investigate this further for you.  

3: Seeker
3: Seeker

7 weeks in no hope of connecting Apple Watch Ultra to one plan somebody not telling the truth.  Must have spoke with everyone but the CEO. No chance👎

Having the same issues.

Is it working now?

Community Manager
Community Manager

@Fedupin2023 - I'm disappointed to hear how many times you've had to contact us about connecting your Apple Watch and how long it's taking. I can understand your frustration. So my team can help, please reach out to us on Social Media

3: Seeker
3: Seeker

Same problem.

It’s been a week and about 7 hours on the phone with them. Each time it’s, 24 hours, Once it was wait 3 days then again 24 hours.

After the first call I lost all calls and I had to go to a Vodafone shop to replace the Sim as they messed it up.

After 1.5 hours tonight, guess what? It will be fixed in 24 hours. 

Ive heard it too many times. 

2: Seeker
2: Seeker



Did you ever get a solution to this problem. I've got a very similar issue. I've moved over from O2, had a temporary number set up for my phone via an eSIM but can't connect my Apple Watch Ultra to the OneNumber account. I get the same message (Oops! A server error occurred).

Hi @spatterman 👋 Sorry to hear that you're having a similar issue getting your watch connected. So we can investigate this, could you please contact our team by following this link, where we will be happy to help.

2: Seeker
2: Seeker

i know this is an old post, i have been having the same issues within the last 2 months with Vodafone and it seems as though no one has a clue what they are doing, every single person i have spoken to has literally done the same process over and over again, im sick of it to be honest. i ended up having to complain through to the CEO's email which i currently have a case manager assigned but still no luck with whats going on... im hoping to have it resovled and set up before Christmas 🤣

I have given up honestly it does not work and seems like it never will so am requesting a refund of the charges paid and to send the watch back as I am just tired of all this. Terrible.