main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

iOS

WiFi Calling taking ages to enable

SOLVED
View solved solution
Highlighted
4: Newbie

I have an iPhone 8 running iOS13.3 and have a poor signal in my house, so have recently enabled WiFi calling. I connect to my home WiFi on 5GHz. What I am finding is that, when I power up the phone, or move back into WiFi coverage, it can take a very long while for the display to show "WiFi calling", and indeed I have missed calls as a result. I have also seen the "WiFi call" display disappear when the phone has been in standby (i.e. display off) for a while. Can anyone explain what's happening and offer a fix, please?

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Moderator

It may be that the phone is trying to connect to any of our mobile network that's available (even if this may be patchy) @nigel2. When switching your phone to Airplane mode does this connect you to the Wi-Fi Calling feature faster when you're at home? This should force your phone to use the feature rather than trying to connect to the network.

Please let me know if this helps :Thumbs_Up:

View solution in original position

View more options
6 REPLIES 6
Highlighted
Moderator

It may be that the phone is trying to connect to any of our mobile network that's available (even if this may be patchy) @nigel2. When switching your phone to Airplane mode does this connect you to the Wi-Fi Calling feature faster when you're at home? This should force your phone to use the feature rather than trying to connect to the network.

Please let me know if this helps :Thumbs_Up:

View solution in original position

View more options
Highlighted
4: Newbie

Thanks Natasha - that does seem to fix it, although it's a pain to have to go in and out of flight mode every time; I would have thought that WiFi calling would have been the preferred option if available.

View more options
Highlighted
14: Advanced member

It's also worth noting that Vodafone haven't bothered to implement SMS with VoWiFi, so you won't get any texts whilst in airplane mode, unlike if you were on EE.

Most phones now default to cellular over wifi, there's a few you can force it to prefer wifi.

View more options
Highlighted
4: Newbie

That would not be a problem for me as I deactivate flight mode once WiFi calling is shown on the display.

 

Do you happen to know whether the iPhone 8 is one of those that is supposed to "prefer" WiFi by default? I couldn't find any applicable setting, and Google didn't turn anything up, yet it is apparent that it defaults to using the network unless you force matters in the way Natasha suggested. (Having done that, it does appear to stay in WiFi calling mode even when network access is restored, at least most of the time.)

View more options
Highlighted
2: Seeker

Vodafone's signal is poor to non-existent in most of my house. My iPhone 8 has Wificall enabled.

Unfortunately when I leave my house the phone does not Search but shows 'No Service" and makes no attempt to reconnect to Vodafone's network.

I can recover the Vodafone signal by going into and out of Airplane Mode but I should not have to remember to do this every time I leave home.

I have missed too many calls recently.

View more options
Highlighted
Moderator

@kjorford When switching down to 2G or 3G does this give you service when you leave home? If your signal is patchy it may still be searching for a Wi-Fi connection to connect to - switching your services down should make it easier for your phone to find an available signal connection. You can find out how to do this when searching 'Select network mode' in our device guides.

View more options