main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Android

Alcatel 3L not sending texts

SOLVED
View solved solution
FT87
3: Seeker

I have a new Alcatel 3L phone today. It's Pay as you Go. It's all set up and I can make and receive calls on it. It's connected to the internet. I can receive texts on it. But it refuses to send texts. I've taken the SIM card out and put it back in, and uninstalled and reinstalled Messenger. Still no solution. Any suggestions?

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
AnnS
17: Community Champion

Hi @FT87 

 

You need to make sure you have the correct text messaging centre number on the phone.  The number is +447785016005

View solution in original position

View more options
7 REPLIES 7
BandOfBrothers
17: Community Champion

Do you get any error messages @FT87 

Have you looked at all the settings in the text messages app.

Sometimes downloading another texting app can help.

I assume you have a text allowance to send texts and your sending normal texts which are 180 characters maximum and you have not added photo's or pictures.

Try clearing the cookies , cache etc of your text app and then soft reboot by turning your phone Off and On. 

Current Phone > Samsung Note 20 Ultra 5G - SM9860 Snapdragon.

Samsung One Ui 3.1  / Android 11.

View more options
AnnS
17: Community Champion

Hi @FT87 

 

You need to make sure you have the correct text messaging centre number on the phone.  The number is +447785016005

View solution in original position

View more options
FT87
3: Seeker

Thanks AnnS,

where would I insert that number? I've found the advanced settings for Messages and originally "Phone number" was None, and Custom SMSC was "None". Do I need to insert the number you gave me into one of those?

 

View more options
FT87
3: Seeker

Hi AnnS,

It worked! I put the number into SMSC and I can now send texts. Thank you.

View more options
BandOfBrothers
17: Community Champion

Have a look at the deviceguides.vodafone.co.uk/alcatel/ 

Your exact model isn't present but looking at the others may help guide you @FT87 

Current Phone > Samsung Note 20 Ultra 5G - SM9860 Snapdragon.

Samsung One Ui 3.1  / Android 11.

View more options
FT87
3: Seeker

Thank you BandOfBrothers, I'd tried that route but not got to a solution. The Community has solved the issue for me.

View more options
AnnS
17: Community Champion

Hi @FT87 

 

This will be in your message settings.  If you are using Android, three dots at the top, settings, more settings, Text messages, scroll down to message centre and make sure the correct number is showing.

 

@FT87 

 

So glad this worked for you.  

View more options