main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Android

WiFi calling option on phone

SOLVED
View solved solution
Highlighted
2: Seeker

I have recently got a Samsung Galaxy S20 and wanted to set up WiFi calling. It is already enabled in my account but there is no option on my phone.

On my previous S7 Vodafone were able to send a configuration message and the option appeared. However, I have just spent 30 minutes on a web chat with Vodafone and the guy didn't seem to understand what was going on. He eventually told me he'd put me in another queue, warned me there was at least an 8-10 minute wait and closed the call!

How on earth can I get the option enabled? I know it's just requires Vodafone to send a configuration file but I don't seem able to find anyone willing or able to do it.

Thanks for your help.

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
2: Seeker

Thanks for your reply. Yup, I had tried all that hence my frustration.

However, I do now know more. I have just made another call to Vodafone and this time I ignored all options and eventually (be patient!) got straight through to the Technical Support team.

I explained the situation and had to run through all (!) the options I had on the phone. Apparently the phone cannot be upgraded while it is on a wifi network so I reset the wifi and they sent me a configuration file. Once I'd restarted my phone, the option appeared.😀

I then restored the wifi and all is well. To test it I put the phone in flight mode, re-enabled wifi and was able to make a call over wifi.

My frustration has subsided. 😁

 

 

View solution in original position

View more options
2 REPLIES 2
Highlighted
17: Community Champion

Hi @DocT 

 

I see your phone model hasn't yet been added to the eligible phone model list in wi-fi-calling although it certainly has the capability to use the service.

This is from an old thread which may / may not help.

"Also look in your online my Vodafone as there is a section to toggle that feature On and Off. Some have found it helpful to turn it Off for 24 hours and then turn the phone Off and On and toggle it back on in your myvodafone "

And go to Phone > Options > Wi-Fi Calling

To add.....

Calling Over WiFi Set up. Ask the agent to force the phone via sending an OTA configuration update that should provision your phone for Calling Over WiFi. 

 

"Register for Vodafone Wi-Fi Calling

Text the word CALLING to 97888

This is a free text which will add the service to your account

You should receive the following confirmation text:

Thanks. We’ll add Wi-Fi Calling to your account in the next 24 hours and will let you know when you’re all set up.

If you’d like to discuss this with us, or if you have any other issues, you can find more info here or contact us

Once you receive the confirmation text, switch on Wi-Fi Calling in your settings

Go to Settings, scroll down and choose the Application icon

Choose Phone and scroll down until you see Wi-Fi Calling – select the box beside this option

A pop-up will appear asking you to confirm if you want to enable Wi-Fi Calling – tap OK"

 

My apologies if.youve tried the above already.

 

🌈 Stay Safe  🌈 

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui 2.1  / Android 10.

 

Samsung Gear s3 Frontier Watch.

Samsung Galaxy Buds.

View more options
Highlighted
2: Seeker

Thanks for your reply. Yup, I had tried all that hence my frustration.

However, I do now know more. I have just made another call to Vodafone and this time I ignored all options and eventually (be patient!) got straight through to the Technical Support team.

I explained the situation and had to run through all (!) the options I had on the phone. Apparently the phone cannot be upgraded while it is on a wifi network so I reset the wifi and they sent me a configuration file. Once I'd restarted my phone, the option appeared.😀

I then restored the wifi and all is well. To test it I put the phone in flight mode, re-enabled wifi and was able to make a call over wifi.

My frustration has subsided. 😁

 

 

View solution in original position

View more options