Showing results for 
Search instead for 
Did you mean: 






Problems with Digital Voice calling iPhones

3: Seeker
3: Seeker

Is anyone else experiencing a problem when calling a mobile - specifically in my case iPhones - using the Digital Voice landline?

I have just moved over to Vodafone Broadband with Landline and whilst the broadband setup is fine, whenever I have tried calling my own and my wife’s mobile form the DV landline, the connection fails.

Sometimes the iPhone doesn't ring, sometimes it does bit cuts off when the the green answer call button is pressed. At the landline end, you hear the call ringing, but when the iPhone attempts to answer, the sound changes to a sort of repetitive ‘honking’ tone and that's it, until the landline cancels the call.

I've tried it with several different landline phones, tethered and cordless - the result is the same. The call iPhone -> DV land line seems fine.

Any clues? 


I was psyching myself up this morning to deal with the rigors of customer service, and did a test call from my Dads landline to my mobile in anticipation of needing yet another example....and (Drum roll!) I actually got connected!!!! This was not the case yesterday, so something must have happened between yesterday and this morning...maybe your complaint worked for all of us!

Strange how all through this saga, Vodafone tech implied it was a carrier issue and there was nothing wrong with the line, yet Steph stated above that that couldn’t be the case as “this isn’t an issue that is affecting a large number of customers”.

Someone, somewhere knows what the DV side of the problem is and appears to be actively solving it. (As was my case).

I’m glad that others too are having their problems resolved (eventually).

16: Advanced member
16: Advanced member

@lcsneil This is excellent news. Is there any way that you can get information about what Motaz actually did, even if all it boils down to is a simple phrase like "I pressed the xyz red button on the abcd screen"? That way everyone else can tell the helpdesk what the required fix actually is.

Clearly we cant possibly reveal that information as we need you to spend another hour of your life with the help desk doing basic checks and putting you on hold again....... 🤣

I did get some information though as to the cause and it appears that the VOIp side of the modem uses a different IP address to the main IP address of the router and the two had got out of sync. Now I know that isnt at all technical and doesnt make sense to someone who knows what they are talking about but it was the best I could elicit. 


Pleased that your problem looks to be fixed. I will be calling 191 this afternoon as my O2 problem still exists.

I wait with baited breath on your outcome..........

Hi @lcsneil. Eventually found time to call the 0191 number and was helped by a very nice support person called Mirette. My problem seems to be resolved and Mirette told me that rather than a hard reset of the router she had completely erased it and rebuilt it.  Apparently a hard reset is not enough. Thought others may find this useful.

16: Advanced member
16: Advanced member

@BBolt She said what? Hmmm, I doubt that very much. I suspect that all that has happened is that the router has been flushed and the latest firmware applied. In the logs there may be a lot of TR69 records, unless they were wiped, see

If you ever are bored and have the free time, unplug the router from the outside world and leave just one wired PC connected, then do a factory reset and it will load an older firmware version from NVRAM. When you next connect to VF it'll be updated. Getting this old router firmware to load was once a way to split the WiFi channels and attempt to get IoT devices re-connected.

Thanks @Cynric, you're probably right but that is what I was told. I'm just relieved that my problem seems to have been resolved.