Showing results for 
Search instead for 
Did you mean: 






Broadband app won’t pair with phone

2: Seeker
2: Seeker

My broadband app won’t pair with my phone, it hangs on the screen that asks me to press WPS for 2 seconds. 

I've tried turning off mobile data, deleting and reinstalling the app and turning my router off and on again. 




WPS enables you to easily connect wireless devices to your Vodafone Wi-Fi Hub. Here, you can choose how you want to connect your wireless devices.

WPS Function
WPS is applied to

Pair your devices by pressing a button

To pair your device, press 'Pair'. Then press the WPS button on the device you want to connect.
Your Vodafone Wi-Fi Hub will be open for pairing for up to two minutes after you've pressed 'Pair.'
Start pairing
On my old VM hub it also gave an option to enter a PIN number.
So the app is deficient to the extent of 1 pairing button.
iOS 10.1 or better?
Daft idea, the base of the hub has a QR code?

View solution in original position


I am having exactly the same issue now - in July 2023. I loaded the vodafone broadband app on both my iPhone and my iPad.

On each device in turn,  I connected to the vodafone broadband app and went through the instructions.

Step 1: On both devices it found the vodafone network and connected to it.

Step 2: The problem comes when you try to connect the app to the router as the next step.


As has been documented here, the only way they allow for Step 2 is via their instructions is to use WPS; and IoS does not seem to support WPS. As soon as you press the WPS button on the router (as it instructs you to - and I have tried long presses, short presses and unplugging as recommend in various thread) all that is displayed is a "something went wrong" message. As is also documented here, the QR code route (itself a work around as you have to claim you are using a different device than the one identified in step 1) only gets you connected to the network again and not the router. 


I understand that you can still use a PC to connect to the router and/or use a browser on your mobile device to access or whatever your router source is. However I and many others (by the look of this thread) seem to have spent much wasted time trying to use an app that does not seem for for purpose on IoS devices (to quote Monty Python: "Not much call for it? It's the most popular cheese in the world").


It would seem - as a software professional of some years standing - that Vodafone should consider putting a message on the app stores that the app will not work with iOS devices: or (heaven forbid) actually test the device using IoS and post on this forum EXACTLY what they did to get it to work. Short taps/installing afresh/unplugging (aka engineers reset) only seem like fudges to a fundamental problem. Doesn't anyone care about the quality of software they publish these days? 3 pages of stuff here and doubtless many other who just bin the app off seem testament to how the Vodafone software development department operate. On this performance I am crossing everything that I don't get technical problems with the router. Come on guys - where's your professional pride?  

Unfortunately the WPS solution does not work with an iPhone.


iOS 10.1 or better?
Daft idea, the base of the hub has a QR code?
Connect in a flash

Give friends and family speedy access to your WiFi by sharing a QR code directly from the app.


Then scan the QR code from the base of the router.

Hi thanks but that doesn’t work.

When using QR from the bottom of the router, it just shows the WiFi name and standard password. I am already connected to WiFi, I just need to pair the Vodafone broadband app with the router.

Can anyone solve this?

Community Manager
Community Manager

Hi @gh2410 You should be able to set the Broadband app up on your phone using the QR code as described by @clint_flick If that fails, let us know what error message you receive and we'll be happy to help 😊

Thanks, but I already replied to @clint_flick.

there is no option when using the app to scan the QR code.

Use the camera app on your iPhone not the Vodafone app

Thanks. But that doesn’t work. That just allows you to connect to the WiFi. I’m already connected to the WiFi.

I’ll just have to bin the app off.


I have this very common issue, Vodafone have created an App that basically only worked when the router had an internet connection. Whenever I had an issue with the router and would just like to reboot it, the App would not connect to the router! Now having split my WiFi connection the router struggling and me deciding to just use one connection in the house, the App will not connect to the router. Vodafone should do better...