Showing results for 
Search instead for 
Did you mean: 






Pro 2 broadband cant connect Ring doorbell

2: Seeker
2: Seeker


I'm not very techy. I can't connect my Ring doorbell which apparently is on the 2.4ghz frequency. I have looked in the general settings and it says 2.4/5/6, but I can't edit these  (it's says go to superwfi on the app but can't seem to do it there either. Can anyone help? The doorbell connected with my last black vodafone hub.

Thank you


Yup I’m sure that’s sadly true, but almost ALL home automation stuff that I have encountered (lights, smart sockets, video doorbells, etc) will ONLY work with 2.4ghz wifi. That means anyone with a Pro 2 ultra router is unable to use any of those devices. The customers who pay the most have the most restricted service. The dozens / hundreds of home automation devices aren’t going to change their devices just because VF has regally decided it doesn’t want its customers to be able to use them as they currently stand.

16: Advanced member
16: Advanced member

Wait until they drop 2.4GHz all together. 😀

Hah! Yes. But since the current implementation is effectively useless, they essentially have done so already.  I’m not sure I’ve encountered any device that will connect specifically to the 2.4ghz band of the combined 2.4/5ghz SSID.

16: Advanced member
16: Advanced member

@jeep wrote:

  I’m not sure I’ve encountered any device that will connect specifically to the 2.4ghz band of the combined 2.4/5ghz SSID.

The devices should have no problem connecting to the 2.4Ghz band, it's the setup apps running on 5Ghz that cause the problem. I've got 2,.4Ghz devices work perfectly (the laptop I'm typing on is one). It simply has no idea the 5Ghz band exists.

If it can be made to work then I will be delighted, because running two parallel mesh router networks is an expensive pain. There doesn’t appear to be a way to force an iPhone to pick a particular frequency. I tried switching off the VF router, creating a 2.4ghz hotspot with my phone with the same SSID as the router, setting up a HomeKit device, then turning off the hotspot and turning the VF router back on. The Homekit (or Ring) device wouldn’t reconnect. I tried this a couple of times. Notwithstanding the fact this is a giant palaver all because VF removed the ability to split the frequencies, is there a reliable way to make this work?

16: Advanced member
16: Advanced member

Here's a suggestion, It's similar to what you tried, so maybe it won't work.

Turn off the Vodafone router. Give the other router the same SSID and password as the Vodafone router. Setup the devices with the other router and then switch it off and the Vodafone one back on.

The devices should then connect to the Vodafone router.

Some people get a cheap 2.4Ghz only tablet, or an old 2.4Ghz only phone and just use it as a configuration controller for the smart home devices.

But yes, it is crazy that Vodafone don't allow the bands to be split.

any devices that you would recommend?

None particularly. As long a it's 2.4Ghz only (or can have the 5GHz switched off) and can run the smart device's configuration app it should be fine.

2: Seeker
2: Seeker

I gave up and took the Ring doorbell back. I also can't connect any of my HomeKit devices which I can't take back and which worked perfectly with my previous ISP. I've never heard of a broadband provider that doesn't allow you to split the frequencies. They might as well say they prohibit smart home devices. 

BT are the same which is why I bought my own router.

I will take the new vodafone deal and just use My own router again.