Showing results for 
Search instead for 
Did you mean: 






Pro 2 broadband cant connect Ring doorbell

2: Seeker
2: Seeker


I'm not very techy. I can't connect my Ring doorbell which apparently is on the 2.4ghz frequency. I have looked in the general settings and it says 2.4/5/6, but I can't edit these  (it's says go to superwfi on the app but can't seem to do it there either. Can anyone help? The doorbell connected with my last black vodafone hub.

Thank you


Hi Gemma,  I did just do that yesterday, we got it working for about 5 mins the ring doorbell then updated, rebooted then no available wifi network channels apart from everyone else in my neighbourhood. The is defiantly an issue with the ultra hub. Shame there's not more setting we can change as a paying customer on the router. I have used a ten year old tplink router turned off the server part so it just broadcasts a wifi signal connected it my booster ring connected first time and works perfectly. There has been a lot of talk on the forums about this issue and the ultra hub but nothing seems to be done about it which is a shame. 


2: Seeker
2: Seeker

Literally nothing you can do other than get a different router. Pretty much every device only works on a dedicated 2.4ghz band, and Vodafone’s insistence on only providing 2.4/5ghz together means the Ultra Hub is useless. Very disappointing because the broadband service itself has been solid. 

16: Advanced member
16: Advanced member

If you have access to a seconds phone:
Take note of the router SSID & Password then power down the router
Set up a 2.4GHz hotspot on the second phone mimicking the SSID & Password of the router.
When the doorbell is set up, you can turn off the hotspot and turn the router back on.

1: Seeker

Hi - In case anyone comes across this thread in 2024 - I managed to find a solution that worked for me. I set my Guest WiFi SSID & Password to be exactly the same as my previous router that my 2.4GHz devices (including Ring devices) worked with. All the devices then auto-connected fine with the guest network!