main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Other broadband queries

Vodafone Router adding .broadband suffix to some network entities

AndyMunn
3: Seeker

Help!

I've been with Vodafone for 3 years and in the past 2 weeks upgraded to Vodafone Pro Broadband with the THG3000 router.

Everything was fine until yesterday when I found I couldn't RDP into my server (valhalla), it was up and running so I did a check in the Router connected items and could see it there fine.  I then used another app to scan the IP addresses on the network and found my server is now named valhalla.broadband.  I notice about 30% of devices connected now have a .broadband suffix which breaks quite a few things I have setup including Sonos etc.

Has anyone got any idea how I can resolve this?

I tried the WiFi experts but beyond a factory reset of the Router which didn't help, they had nothing further.

Thanks! 😬
BTW, the Firmware version is: 

19.2.0307-3261019-20201215123003-87d129527e2b6c5db641b036118778179b03c3da

Bootloader version:

19.02.1146-0000000-20190110090550-897d2844f012557134a272eb8a8a90f85e9a7a8d

Hardware Type & Version: Vox3.0v
View more options
8 REPLIES 8
KeithAlger
16: Advanced member

So, I have to work from memory here but somewhere in the expert settings there used to be a setting for the local network domain name, and by default, it was set to broadband.  You can't not have that setting there, but if you change it to local it should give you fewer issues.  Depending on how the VF routers have been set up it may then enable you to access your server as either valhalla or valhalla.local (ie on many routers .local can be omitted).

 

* I also run a local DNS on my Raspberry Pis, and so have "modem" and "modem.local" pointed at the modem even though it's sat on a different subnet.

 

**If you can use a browser to access other named devices on your network, you'll probably find you can access some of them with both, just their own name and also with the .broadband suffix.

 

Do let me know if that helps at all!

 

 

View more options
Cynric
12: Established

If ".local" doesn't work, try ".lan" which is a common default too.

View more options
gipjon
16: Advanced member

this may sound like a real daff question but why did you upgrade to pro broadband. 

View more options
AndyMunn
3: Seeker

Many thanks for replying, what you are saying makes sense, but after a *lot* of searching around in the router settings I couldn't find anywhere I could change the local domain suffix.  I had a look in the VF forums, and it seems that VF in their infinite wisdom has removed the ability to change this (I think it was in: Expert Settings >> Settings >> Local Lan)

I've gone back to the previous router just now, but I will persevere with the new router as I like the idea of the automatic switch to 4G if the network goes down.

Are you using pi-hole on the Raspberry Pi?  I am thinking I might need to set up a local DNS to resolve my problem eventually.

 

 

 

View more options
AndyMunn
3: Seeker

It's not really a daft question, I think the short answer is marketing.

The longer answer is they offered me the upgrade for £1 more a month for the new router with 4G fallback plus a £75 Amazon voucher.

I've been happy with the VF service, but the new router is making me question my decision.

View more options
KeithAlger
16: Advanced member

Reading back to an earlier post I have 2 PiHoles set up, and I have them running in combination with unbound which works as a recursive DNS - ie the only time anything on my networks looks to an online DNS is when it's not held locally.  The Pi-holes cache and filter but unbound goes a little further although it's less friendly!  *I could run Diversion (another filtering caching DNS) on the router, but it's harder to temporarily disable if you need.

 

The last time I tried to run Pi-Hole on a VF router was the HHG2500, and with the firmware I had, it would not (at that time) use a DNS server within the LAN!

 

I would hope that you could now use a local DNS, though I'm unable to test this.  If you want to set up a Raspberry Pi to do this and nothing else the 2GB version is more than enough.  Add a passive heat-sink case and set up the Pi to boot from a Sandisk Ultra Flair USB 3.0 (most of these are actually USB 3.2 now), and it'll do everything you need, quick and silently!  *I've used one of the Pi-Holes to provide DHCP and it was flawless, however I now run DHCP with some extensions on my 3rd party router.

View more options
Cynric
12: Established

I also have Pi-Hole, but also I ran another router after the VF one, so the VF THG3000 connected to the outside world. So for starters I had none of the VF issues related to a number of settings or other limitations. With the Pi-Hole doing its job too I didn't have DNS or DHCP worries with local devices.

View more options
rackem42
2: Seeker

I run a separate DNS, DHCP, and Access Point using OpenWRT, which for me eases the transition between ISPs: On receiving the ISP router I simply switch off its DHCP & WiFi. No need then to go to all my devices and key in new WiFi connection details. FWIW I use the .lan suffix.

 

The THG3000 Vodafone router is easily the most restricted one I have ever been given, even to the point of being forced to use a /24 network!

 

I too ended up with the .broadband suffix issue you are facing, and with the same kind of symptoms.

 

After much head scratching, and as a last resort, at the Vodafone router I switched off IPv6:  In Advanced Mode it's Settings 》Local Network, and as well as toggling off IPv6 I have everything else here disabled,

 

After disabling the IPv6 option here the issue went away.

View more options