main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

iOS

Apple Watch series 6 can’t connect to data plan

dnldav005
2: Seeker

Hi all - had read through this post with great trepidation having received my new Apple Watch SE from Vodafone and had the same “top of the mountain/too many subscriptions” problem with One Number. 
Multiple calls to 191 but finally a solution which worked was to do an e-sim swap, to provision my one number plan against my Apple Watch EID number. The instructions I received were per below and worked within 24 hours of attempt:

 

Dear Customer,

? In order to activate your eSIM
? Kindly Log in to your account and go to Account settings
? Go to Swap your SIM, then Choose your watch from the drop down list (*“MobileSecondary” in my case)
? Click Go to eSIM swap and paste or type in your Apple Watch eSIM ID number (EID).

 

hope this helps some of you.

View more options
klausinthehouse
2: Seeker

I got a Series 6 Apple watch today that is showing "No Data Plan" and having read a couple of threads on this board, I really want to try this, but I have no "mobileSecondary" as an option.

 

For starters, when I was setting the watch up earlier today, it was suggesting that I subscribed for an extra £7 to use my watch with my data, minutes and texts. This seemed odd as I thought I was paying £29 a month to use my watch with my data, minutes and texts. At that stage the Vodafone subscription page my phone kept forwarding me to said that my login didn't exist and if I clicked on register just to try and encounter any sort of procedural advancement over the loop between two pages, it said that my login was already in use. Did it not exist or was it already in use? After contacting the online live chat it appears that the operator fully cancelled my OneNumber chat as when I called up 191 to get some clarity I received a text saying my Vodafone insurance policy had been cancelled whilst I was on the menu. 3 people and one hour and 25 minutes later and it turns out my account was cancelled by the operator on live chat for no reason, it should be reconnected within 24 hours and I shouldn't be prompted to pay an extra £7 a month because everything that service provides is within my £29 monthly fee. I just really hope this isn't the first of many more "wait 24 hours". I've had a bad run of things with Vodafone in the past and have ended up sticking with them as they have made a decent effort to rectify things afterwards, but another saga of being bounced around customer service and tech departments endlessly would be the straw that broke the camels back.

If there are any Vodafone support folks on this thread, could you please help me reach a satisfactory conclusion. After having spoken to Customer Services earlier today I no longer get held up during the "setup data plan" whilst configuring my phone with my watch, but it still says "No Data Plan" when swiping up on the watch face and if I go to the Mobile Data menu within the watch app it says "Vodafone UK waiting" as per the attached image.

 

IMG_2893.PNG

View more options
Evie
Moderator

@LBattyUK @KJR82 Hi guys, I'm disappointing you're still having issues with your Apple Watch plans - we would need to run through some trouble shooting and tweak your account a bit to get this sorted, and as we don't have access to accounts over the forum could you contact us on social media please? Make sure to include a link to this forum and your username in the private message so you're not having to repeat yourselves

@dnldav005 - I'm glad to hear you're up and running now 😊 If you did need anything else, don't hesitate to get in contact!

Hey @klausinthehouse - Really sorry to hear the hassle you have been through in attempt to get this sorted - I would advise to follow the contact us hyperlink above so that we can get you up and running with your Apple Watch 👍 Be sure to include a link to the forum and your username in the private message.

View more options
LeeBfc
4: Newbie

Did you get this resolved I’ve been having issues connecting now I’ve also got his waiting message from this morning as well? Any help appreciated 

View more options
KJR82
2: Seeker

Nope! 2.5 months in... 

View more options
t_alpha
2: Seeker

I'm having the same problem. Originally I was getting the registration screen, whereas now I'm getting error code 2004. However my Watch says the Network Provider is "vodafone UK 14.0", despite there not being an ICCID.

 

The screenshots below are displayed in the exact order they occur in. The last one shows the mobile data toggles even though there's no data plan, but as soon as I exit the mobile data section and go back into it, these toggles disappear (as per screenshot #2).

 

After selecting "mobile data"After selecting "mobile data"

 

 

The "loading plan" times outThe "loading plan" times outIMG_7908.PNGIMG_7909.PNGError page!Error page!Closing the error page now displays the mobile data toggles, minus the data planClosing the error page now displays the mobile data toggles, minus the data plan

View more options
MarkD
Moderator

@KJR82, have you sent our Social Media Team a message over Facebook or Twitter? 

@LeeBfc & @t_alpha, we will need access to your Vodafone account so we can help. If you send our Social Media Team a message and include your Community username, the team will help to get your Watches connected. You can find all the contact details here

View more options
sreeramkumars
2: Seeker

I have the exact same problem trying to activate my Watch SE with vodafone one number both online and via customer services. It's been a week now and the subscription gets activated only to be cancelled within few seconds.

View more options
nom
2: Seeker
2: Seeker

Hi,

 

I had this problem too. I fixed it by doing a sim swap. 

I went to here: https://www.vodafone.co.uk/help-and-information/esim 


Click on esim to esim. 
Logged into My Vodafone 

Select your number 

6F9101F4-6495-47E0-8D59-3BC50F46E511.jpeg

Press continue. 
Now select Mobile Secondary 

5020E51D-55FD-485B-913F-EF09C91EB787.jpeg


The screen will change

F0616091-A1E2-42EB-9F36-0DF0E346A37D.png

Press Apple Watch

Press continue. 
Enter the EID number in the box. This can be found in the watch app under General > About 

 

Finally tick the boxes to agree and the esim will be provisioned or more re-provisioned. Now fully close the watch app. Wait a few minutes.  Go back into the watch app and the data plan will be active. I did find it showed inactive at first but keep waiting. In my case it took about 5 minutes although it can take 24 hours. 

I hope this helps someone with the same issue. 

Best wishes,

 

Tom. 

 

 

 

 

View more options