main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

This is a locked archive and content on this page may no longer be up to date. These posts and threads have been archived for reference only.

Archive

SureSignal Problem: Something worth a try

Highlighted
2: Seeker

My Galaxy S7 used to work OK with my SureSignal v3, but then it stopped connecting.

I knew the SS was OK as a second mobile registered on the SS had no difficulty.

After the usual, frustrating 2 week run-around, multiple chats, broken promises and phone calls to 191, I have found a solution.

Here's what I did:

1. Unplugged the SS and left it for a couple of hours.

2. Removed the ethernet cable.

3. Pressed and held down the SS reset button before plugging it in to the mains again.

4. While still holding the reset button pressed in, I plugged into mains and continued to hold down the reset for about 30~45 seconds.

5. Released the reset button and then plugged in the ethernet cable.

6. When all 3 lights were up I powered off the mobiles and powered them on again.

Both phones then worked fine with the SS.

Although this procedure worked for me, I can't guarantee that it would work for anyone else, but it's worth a try.

View more options