Showing results for 
Search instead for 
Did you mean: 






My vodafone wifi has stopped letting my phone open apps

3: Seeker
3: Seeker

I recently renewed my WiFi package with Vodafone for the exact same deal, didn't have to do anything but reset the router on the day. However since doing this my Samsung phone has started having problems loading up some apps and stuff in apps. For example the Premier league app has stopped working. Twitter and reddit videos don't load but those apps and pictures load just fine. Random stuff like trying to send gifs on WhatsApp doesn't work.

When I turn off the WiFi these apps open up as normal on my mobile network that is also through Vodafone so I'm confused. I can also connect totally fine to them through my work WiFi so ot is just my home broadband and it has only started since the new package. My wife's phone and all other devices in the house don't seem to be effected. 

Any advise on this would be appreciated


Hi Janey, after more troubleshooting today, I have managed to fix this issue. It had something to do with the IPv6 being checked on my router settings. After unchecking this, all my apps work completely fine and as they should. 

Thank you all the same!

View solution in original position


Glad you got it fixed! I broke down how to fix the issue in a post here but it seems the admin has pinned another post as the solution. @Janey Would it be possible to have the linked post as the solution? Thanks! 

3: Seeker
3: Seeker

I've just posted re the exact same issue (having not spotted this thread). I'd listed a few things I'd encountered, but having read here I've now noticed that I also can't use gifs and videos aren't loading in certain social media channels etc.

Its not a huge help given that it didnt last, but worth flagging that last night I spoke to customer support and after trying many things, they changed something at their end relating to content controls and it immediately fixed every issue I had. It sadly only lasted an hour or two, but there's maybe something in that to help pin the issue down (I'm planning on reaching out again tonight but thought I'd try on the forum first)

4: Newbie

Screenshot 2023-11-09 at 18.55.19.png

After disabling all the IPv6 settings, my problem (which is the same as yours) persists. No luck. Is your firewall enabled?

Yeah,  firewall is still enabled,  the only change I needed to do was uncheck the IPv6.

Sorry,  I don't have any other idea what it could be,  unchecking the IPv6 option has worked for myself and multiple other people now with this issue, so it sounds like it's not the same problem. 

Have you tried other solutions? After trying the solutions did you revert the changes back to default after they didn't work, including any changes you may have made to your phone too? The ONLY thing that seems to need to be done is the IPv6 unchecked.


Hey @Jack20991 @RJFINN03 @salvom89

We’ve identified a routing issue impacting a small number of users who use Android apps and it’s currently being looked into. Sorry for the disruption caused, we're getting it resolved as quickly as we can. If you need more help with this, please speak with our Broadband Tech team on 191 free from a Vodafone mobile or 03333 040 191 from any other phone. They're also available on Live Chat.

Unfortunately I have no Android devices but this affects Apple and Samsung TVs as well.

16: Advanced member
16: Advanced member

@salvom89  Go to the router LAN settings and turn off all references to IP6. That may help, it has else where


Already tried, unfortunately it didn't work. Thank you anyway.

Thanks for letting us know @salvom89 Give the Broadband team a shout on the channels I mentioned earlier and let them know - hopefully we can see a fix soon.