Showing results for 
Search instead for 
Did you mean: 






My vodafone wifi has stopped letting my phone open apps

3: Seeker
3: Seeker

I recently renewed my WiFi package with Vodafone for the exact same deal, didn't have to do anything but reset the router on the day. However since doing this my Samsung phone has started having problems loading up some apps and stuff in apps. For example the Premier league app has stopped working. Twitter and reddit videos don't load but those apps and pictures load just fine. Random stuff like trying to send gifs on WhatsApp doesn't work.

When I turn off the WiFi these apps open up as normal on my mobile network that is also through Vodafone so I'm confused. I can also connect totally fine to them through my work WiFi so ot is just my home broadband and it has only started since the new package. My wife's phone and all other devices in the house don't seem to be effected. 

Any advise on this would be appreciated


Hi Janey, after more troubleshooting today, I have managed to fix this issue. It had something to do with the IPv6 being checked on my router settings. After unchecking this, all my apps work completely fine and as they should. 

Thank you all the same!

View solution in original position


Ah I'm really pleased to hear that @RJFINN03 I'm glad you managed to get it sorted!

I disabled the IPv6 settings on Local network but I haven't noticed any difference yet...

It wasn't immediate for me - might be worth forgetting/reconnecting to your network. I did that (but the quicker way of switching airplane mode on and off), then it all seemed to work fine...

Possibly try restarting your phone? Something as simple as that sometimes helps with connection issues. Outside of that, did you make sure to apply the settings after unchecking IPv6 in your router login at the bottom of the page? Also there may be 2 IPv6 checks, the other might be under "WiFi 2" on the same page as local network, if you're using that, you'll need to uncheck that as well. 

Apart from that, I have no other ideas for you other than to contact Vodafone. 

Vodafone is useless, there is no issue for them. Anyway yes, I've disabled all IPv6 settings, and I will try to restart my devices if that helps. Thank you for the advice.

Amazing, just home from work and tried this. Working now. Thanks very much!

After 3 days on chats with the Broadband Team and a referral to the Tech 2 level........ This worked like a dream. '

I' ve no idea why IPv6 would cause the issue but it did for ALL my android devices but not my wife's Apple ones or my Windows laptop. 

Can I ask how you did this please? I'm having exactly the same problem but I cant see a box to uncheck and when I phone I'm getting no help


I found it changing from Basic settings to expert and then it was under Settings then Local Network. 


Thank you so much! Everything is working as it should now, its so frustrating that no one on the helpline seems to know about it. Thank god for this chat!