Showing results for 
Search instead for 
Did you mean: 






Data SIM not connecting to Internet

4: Newbie

I just purchased a (Vodafone 15GB Pay As You Go 90 Day Data SIM) for £24.99, to use in my unlocked Netgear M1 (MR1100) 4G LTE Mobile Router, but unfortunately it refuses to connect me to the internet.

This is how I'm connected:  Laptop PC ----(ethernet cable)---- Netgear M1

Logging into the Netgear M1 administration web page dashboard, it shows that the SIM carrier is ‘Vodafone UK’ and it shows a good signal strength, but says that my mobile broadband is disconnected. If I install this same SIM into my old Vodafone K5161z dongle it connects to the internet automatically, with no problems.

As the Netgear M1 is not a Vodafone product, are there additional steps I need to take in order to get this SIM to connect to the internet using the Netgear M1?

  • APN settings?
  • Must the SIM be registered through My Vodafone, first, in order for it to work in non-Vodafone equipment? (when using the Vodafone K5161z dongle it never required me to register a SIM – it simply worked straight away)

I also downloaded and installed the free Vodafone Mobile Broadband app onto my laptop, but it also failed to find the Netgear M1 with the Vodafone data SIM – “Your device could not be found”. In order for this app to work, does it have to be connected to the Netgear M1 via USB only?    Laptop PC ----(USB)---- Netgear M1


Any help and advice would be most welcome


4: Newbie

I’ve now gone a bit further:

I registered the Data Only SIM by creating a new MyVodafone account using the SIMs mobile number, which as far as I can see was successful. During the registration process Vodafone sent me through a number of authentication text messages which the NetGear M1 received fine. (which at least proves that the SIM is working at a basic level within the NetGear M1).

I also created a new APN profile on the NetGear M1 using the following settings:

  • APN:
  • Username:  wap
  • Password:  wap

Unfortunately, the status of the SIM still shows as ‘Internet not Connected’.

Does it take some time for the SIM to now become active for internet e.g. 24 hours?  Or is there yet a further step I must take? (see below)

I have read somewhere else here that after the PAYG Data Only SIM has been registered, it then needs to have its inbuild credit (24MB  90 Days) converted into a Data Pack in order to get the internet to switch on. Is this really true?

Community Manager
Community Manager

Thanks for reaching out to us @Nimbus1 and for explaining what you've tried so far 👍

What we can do to help is to check your SIM, to make sure it's set up correctly and also see how it's updating on the network. 

So we can do that, please pop my team a message via Facebook or Twitter so we can take your details securely and if you include a link back to your post, you won't need to explain things again 🙂 

1: Seeker

I have the same problem.  I have inserted by PAYGO SIM into my ALFA NETWORK Outdoor 4G/LTE Cat. 4 Global USB Modem (Tube-U4Gv2).  I get the message on my router : “connection Status - not connected”.

If I try an O2 Sim, or a Three Sim - It works fine.

If I try my Vodafone Sim in my phone - It Works fine.

What could be causing this issue?

Community Manager
Community Manager

Hey @mfish152, I'm a little confused with your message, as it appears you've said your modem works fine with a Vodafone SIM in. But if you're having a problem connecting when you have a Vodafone SIM in your modem, pop us a message via our social channels and we'll be more than happy to take a look. If not, but you are struggling to connect with another providers SIM inserted, you'll need to contact them directly