Showing results for 
Search instead for 
Did you mean: 






Huawei 5G CPE Pro and Unlimited Max SIM - No 5G

2: Seeker
2: Seeker

So I purchased an unlocked Huawei 5G CPE Pro and a Unlimited Max SIM-only plan from a Vodafone store. For some reason with this SIM card I am only getting 4G+ and not 5G. If I put my other Vodafone SIM card which is a 160GB plan I do get 5G on the router.


I have so far had 5G added through the eConfigurator in store as it wasn't originally on there and had a manual disconnection/reconnection and that didn't solve anything. I have been back into the store and the cancelled the plan and created it again with a new mobile number and SIM.


I have tried it in the router again and I am still not getting 5G. I am wondering what else can be done? Does the SIM card need to go into a 5G phone first to provision the 5G and then go into the router? My personal phone is an iPhone X so doesn't have 5G, but I have tried my 160GB plan SIM card in a iPhone 13 Pro and it got 5G on there.


If anyone has any suggestions it would be much appreciated.


Moderator (Retired)
Moderator (Retired)

Hey there @HarrisonC - This is a strange one 🤔 It sounds like the issue is with the SIM card. I would advise to drop us a message on social media so that we can look further into this for you and check your account. Make sure to include your mobile number and a link back to this forum post to save you repeating yourself.

Hi Evie, already in contact with your social team. Been escalated to the Super User team for a second time now. Don't think its the SIM as the store completed cancelled the contract and created a new one with a new SIM.


I have purchased a 5G-ready phone to try and see if I get signal on that but am doubtful.

Community Manager
Community Manager

If you connect to a 5G service with the SIM in another 5G device in the same location, this sounds like it could be connected to the device. Have you checked the settings to make sure everything is set correctly? You'll be able to find more information on how to check this through the manufacturers support pages.

Hi all,


So I purchased a 5G phone today and put the SIM card into it and it got 5G service after some time. I then put the SIM back into the router and its getting 5G service now.


I believe, for some reason, that the 5G CPE Pro cannot provision the 5G service directly and requires a phone to do this (at least initially).


So issue is now resolved, but still scratching my head as to why.

Community Manager
Community Manager

Yes, that does sound a little strange @HarrisonC 🤔 As long as everything's up and running as it should be, that's the important thing.