main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Mobile Broadband

Prevent Mifi from roaming?

SOLVED
View solved solution
Renny
2: Seeker

We have a "Mifi" - Vodafone Mobile WiFi model R219h which we bought for use in our flat in Warrenpoint, UK.

 

It seemed to work fine but it turns out the Mifi was connecting to Vodafone 4g in the Republic of Ireland, just across the water.  This quickly used up the roaming data allowance on the account and now the Mifi is essentially useless until the next billing period.

 

I'm trying to find a way to force the Mifi to NOT connect to the (stronger?) roaming signal and instead use the unlimited non-roaming data allowed by our account.  Fiddling with the data roaming and automatic network connection in the Mifi's settings doesn't seem to help.

 

Anyone got any ideas?  Or is the Mifi essentially not fit for purpose this close to the border?

 

Thanks!

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
Tash
Moderator

I know you've mentioned you've tried changing the network previously @Renny - was this when changing your network mode to manual rather than it being automatic as shown in the steps of our Device Guide? Doing this should allow you to choose Vodafone UK as your preferred network.

View solution in original position

View more options
4 REPLIES 4
AnnS
17: Community Champion

Hi @Renny 

 

You will be able to turn data roaming on and off.

 

From the device guides here: Vodafone R219 > connectivity > connection settings > turn data roaming on or off  > click save

View more options
Renny
2: Seeker

As I mentioned, I've tried that to no avail.  When I disable data roaming, the Mifi _still_ connects to Vodafone Ireland instead of Vodafone UK, but does not allow any data services at all.  What I need is a way to force the Mifi to connect to Vodafone UK.

View more options
Tash
Moderator

I know you've mentioned you've tried changing the network previously @Renny - was this when changing your network mode to manual rather than it being automatic as shown in the steps of our Device Guide? Doing this should allow you to choose Vodafone UK as your preferred network.

View solution in original position

View more options
Renny
2: Seeker

Thanks - the guide you linked to was helpful.

View more options