main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

4G not working

SOLVED
View solved solution
Moderator

@Goldmaxx I'm sorry to hear you're having issues with your 4G signal. Can you please provide the full postcode of the affected area? We'll then be able to check for any known network issues in the area. 

 

Have you tried your SIM in another phone at all? This will help diagnose if the issue lies with the SIM or the handset itself. If you also restart your phone or pop it into airplane mode, this will allow your SIM to reconnect with our network. 

 

Please let us know how you get on.

View more options
1: Seeker

Been having this same issue since May. Have spent hours and hours on the phone with Vodafone but am now thinking it's time to move networks.

 

Absolutely disgusting service from Vodafone and they never keep you in the loop, then they wonder why you are angry.

 

All they can tell me is that they are unable to turn the 4g on on their system from within my profile and that they are working on the issue.

View more options
Moderator

@Ab1984 I'm sorry to hear you're having problems receiving 4G on your phone. 
As you've advised there's a problem with your phone or account settings, we'll need to take a closer look into this for you. So we can help you further, I've sent you a private message with details on how to get in touch with our team 😊

 

View more options
1: Seeker

Hi Alex. Im new here and I have the exact same problem. I've gone through the steps mentioned in this tread and I still cannot get 4G to show up. I wonder what the solution to the issue was? Can you help me resolve it too please? Thanks.

View more options
Moderator

Hi @telmafernandes we're more than happy to check your account just to make sure you have 4G enabled on there. Please send us your details on the private message I've sent you.

View more options
2: Seeker

Hi 

 

I seem to have this problem too. No 4G at all just 3G or E anywhere, and I should get good coverage. 

 

Tried all things in this thread, installed the settings again, turned phone off multiple times, turned data off and on, etc

 

Any chance you could give it a go from your end?

 

Thanks

View more options
Moderator

HI @simmi84 we're happy to take a look at your account and look to get to the bottom of this. Please contact us by following the steps on the private message I've sent you. 

View more options
2: Seeker

Hello, I have the same issue as the above two posters. Can't get 4G to show up at all. Could I have my account checked please?

View more options
2: Seeker

Okay, I believe the issue is a Split Port as I have the same problem as described in this thread:

https://forum.vodafone.co.uk/t5/iOS/I-am-not-getting-4G-signal-on-my-Iphone7-joined-Vodafone-since-5...

Could someone set this in my account correctly please?

View more options
1: Seeker

Hi, we have a similar problem with a new Vodafone sim and have carried out all suggestions made here and during chat to no avail. Can someone please fix this ASAP.? Definitely not happy with the Vodafone UK experience. 

 

View more options
Moderator

So we can look into the issue you're experiencing with your service @KodaItaru and @loopylorn, we'll need access to your accounts. So we can do this, please get in touch by following the instructions in this private message.

View more options
1: Seeker

Hi. I’m a new payg customer and also having the same issue described above. Can this be checked please. Thanks

View more options
Moderator

Sure thing @Wilkinson88! So we can take a quick look at your account and also get more details from you, follow the steps I've sent you on a private message

View more options
1: Seeker

Hi Adam, 

I read the whole thread and tried it all. Still no 4G. please help. 

View more options
17: Community Champion

There's probably nothing you can do yourself, @FlavioKi.   Just wait for the forum team to pick up your post.

View more options
Moderator

I'm sorry to hear that you're continuing to experience 4G issues @FlavioKi. I've sent you a private message with information on how to reach our team directly. Once we receive the requested details from you, we'll be in touch as soon as possible.

View more options
2: Seeker

Can someone look at my account think i have the split port issue 4g doent work on a number of phones with my voda sim. other sim cards allow 4g on my phone

View more options
Moderator

So we can check on your account and help resolve the 4G issues you've been experiencing @ifon501, I've sent you a private message with details to reach our team. We'll then be able to assist further once we receive your details.

View more options
2: Seeker

Hello, I have the same issue as the above  posters. Can't get 4G to show up at all. Could I have my account checked please?

View more options
2: Seeker

Hello, I have the same issue as the above posters. Can't get 4G to show up at all. Could I have my account checked please?

View more options