main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

Pay monthly

Can't receive incoming calls while abroad

2: Seeker



I have a Samsung S8 on pay monthly, data roaming enabled, bags of data etc and am UK based.


Whenever I am in Spain, I can make outgoing calls, make and receive texts and  use all my data allowance. But if someone phones me,  my phone doesn't ring.   It's got to the ridiculous situation where someone back home has to text me and ask I call them in order to have a phone chat.


Like other similar enquirers, I have wasted countless hours to vodafone call centres.  Generally the ever-so-nice call  centre folk think it's a problem with call barring or voicemail options.  Yet, every time they fail to solve the problem.


Desperate now!  Is there a solution short of switching to a new contract with an alterntive mobile company?!






View more options
17: Community Champion

Hi @marklucas1


 If you are roaming on Vodafone ES, as far as signal and reception is concerned, you shouldn't have any problems.


The first thing to do is to look at your call barring settings on your online account, there is a restriction for incoming calls while abroad, your phone will also have an incoming call roaming restriction on the call settings.


Live chat or Customer Services should be able to look at your account and make sure there is nothing at account level preventing you from receiving incoming calls whilst abroad.  However, if you still need help, do come back to the forum for help from the forum team.

View more options
16: Advanced member

When people are trying to call you when you're in Spain, what do they hear on the line?

Are they routed straight to Voicemail or do they get some other message?

View more options
2: Seeker

I think they went straight to voicemail.


However I have finally fixed the problem by disabling then re-enabling receipt of calls and texts when abroad.  It's very peculiar as in the many call centre calls previously, Vodafone said they had enabled international incoming calls.  Can only guess it's the time tested method of turning something completely off and then on again which fixed the issue.

View more options

@donnyguy If you're currently in Spain and you're unable to answer your phone, it should be routed to your usual Voicemail message 🙂

@marklucas1 I'm pleased to hear the issue's now been resolved and you're able to receive incoming calls, whilst roaming abroad. If there's anything else we're able to help you with, don't hesitate to pop us a message.

View more options