main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle
Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Pay monthly

VeryMe rewards not working

Highlighted
2: Seeker

My number was transferred over from a Vodafone pay and go sim to a Vodafone pay monthly sim on the 6th May 2020, however since then i have been unable to go into very me rewards in my vodafone app. Every time i click on very me rewards its says pay and go customers must have topped up with at least £10 in the last 6 weeks. I am a pay monthly customer and it clear shows that in  my vodafone app. I have spoken to the technical team and they said they will fix this within a few days but nothing. I have used the online chat and i was referred to the very me team, however the very me team number provided does not work and when i emailed the very me team they simply gave an automatic reply to open a chat through very me, which i cannot do because i cannot even get into very me. Absolutely dissappointed with Vodafone in every way. Just waiting endlessly and do not know what else to do. The number porting was successfully done and everything else is working fine except just the very me and I have repeatedly tried reinstalling the app.

View more options
4 REPLIES 4
Highlighted
17: Community Champion

Hi @Prince19 

 

I'm wondering if it would help to set up a new myvodafone with a new email address and password due to the change in contract type !

I appreciate you've tried Live Chat without success.

If not then perhaps try the Vodafone Social Media Teams via Contact-us-for-account-specific-queries as they have account access to help @Prince19 

Link back to your thread here when you contact them.

I recommend Twitter.

 

🌈 Stay Safe  🌈

Current Phone > Samsung Note 10+ 5G _256Gb > Model: SM-N976B.

Samsung One Ui 2.1  / Android 10.

 

Samsung Gear s3 Frontier Watch.

Samsung Galaxy Buds.

View more options
Highlighted
17: Community Champion

Hi @Prince19 

 

As your online account is showing correctly as pay monthly and the application goes by the online account, it sounds like you are reinstalling the back PAYG version of the application.

 

I would recommend going into the application from your settings and clearing cache and data, if you log onto the Application, you can also reset the application from the settings.

 

If problems continue contact the Social Media Team, for a quick reply, I always recommend the Twitter route.

 

edited to add:  If you did not factory reset the phone after transferring from PAYG this may be necessary to clear the phone of any previous stored PAYG information.  You would also have needed to change the APN settings from PAYG to pay monthly, to locate your account, for the first log in you would need to use mobile date.

View more options
Highlighted
2: Seeker

Thanks All, however after trying everything problem still the same. I never used veryme as a pay and go customer, always as a pay monthly customer and it is definetly something on Vodafones end just like the same problem i had porting my number over which took weeks while i was without any network, however somehow i got through to Mohammed (supervisor) in the billing team and he ported my number over and set everything up on that one call in a few minutes, all while the techincal team been working on it for weeks. Anyway i have raised this via twitter and they are looking into it. Will keep this thread updated.

View more options
Highlighted
17: Community Champion

Hi

For new accounts, my understanding is that MyVodafone won't work fully until your first bill has been produced, so it could be that. Can you wait for that and then see if you have the correct access?   If not, the Social Media team can arrange for the account to be deleted so that you can set it up again (you can do so with the same details as before) and all should be well.

I had to have this done recently and it's worth pointing out that you won't get a notification of deletion, so keep checking until you're denied access, then proceed with a new setup.

View more options