Showing results for 
Search instead for 
Did you mean: 






Connecting Apple watch to mobile network -headache!

2: Seeker
2: Seeker

Hi All, 


I was wondering if anyone has had the same problem as myself or know of a fix!


I signed up to Vodaphone sim only xtra plan and as usual given a temporary number whilst my other number is updated from voxi. 

Whilst this was processing I set up the sim in my phone and was able to connect my watch to my plan and subscribed to the one connect - all is good!


The next morning my number updated and was sent an email saying my one connect service would be temporary unavailable whilst my number updates and would be notified once done, sure enough within an hour i received that email with everything now all set up and back working.

I checked my watch and could see there was no plan under the sim and the status said no connection.


It has now been 10 days since this issue has started and i've spoken to around 15 agents over chat and two on the phone with absolutely no help whatsoever, below are the steps we have tried (on numberous occasions) to get it working;

1: unpaired/paired watch ( must have done this around 11 times)

2: Reset watch to factory settings

3: updated my E-ID number both myself via online account and to advisor on phone and over chat

4: Reset my network settings on both watch and phone (Multiple times)

5: cant tell you how many times I've waited 24 hours for back end issues to be updated and promised that all would be working by the next day.

6: went into a Vodafone store to speak to advisor and they had no clue what the issue could be!

7:  spoke to Apple tech support who screen shared my phone and went through all my settings to check everything - all is fine on my end with devices, he said that Vodafone aren't sending the ICCID number and info across .

8: I suggested to Vodafone to cancel my current one number subscription as this was created before my number was updated and now my number has moved across ok to then resubscribe - this has been done and the issue is still the same.


I'm now when I try to set up the mobile plan through the watch app i get the splash screen from vodafone saying 'oops there's been a server error'.

it wont even connect to the one connect website.


I login to my one connect account and can see that the subscription is active and the correct E-ID number is displayed.


I was promised that today it would be fixed but guess what still nothing and was due a phone back at 12:30 and still nothing  - not a great first impression of Vodafone,




2: Seeker
2: Seeker

I'm having this exact same issue, with the same challenges of the hornedous bot chat being no use, the over the phone calls not being able to do a thing. The in store staff are more helpful but not able to fix so far and I'm not able to get into a store easily due to work commitments makes this issue more annoying.

Currently paying for a service that I had working for the short time I was on a temporary number. Making wish I had never moved networks currently and now seeing as this is an old issue  that still happens. 

Reqire the sim on watch service due to my sport being on the water and after a few occasions where I've ended up requiring to phone for assistance and carrying a phone is not an easy option.


Hope someone can assist.


Got to a point where I have given up, it became apparent and no disrespect intended here but seems as though the whole of Vodafone a company so massive worldwide they could not find a senior technician to assist me and help, I made it clear to them the issues and what’s needed as advised directly by apple but they chose to ignore that. I’m beyond angry and for someone who has been with Vodafone 15 years or so I never thought they would treat a loyal customer like this. 

Same problems horrible spoke to customer service agents so many times months and months - replacement watch sent etc. It is not working and probably never will.

Community Manager
Community Manager

Hi @CAKILG - it's not good to hear you've had to contact us so many times and your watch still isn't connecting. Please message my team on one of our Social Media channels and we'll take a look at what's going wrong. @Nik242 - thanks for your feedback. I'm glad to hear we managed to get it working. 

I have reached out on twitter. After countless hours, months of wasted time and frustration, I just want a refund and really don't want to deal with this any longer. I would like to return the watch and receive compensation and reimbursement for all of this - very unhappy at ever having gotten the stupid watch and want to be rid of it now.  Since getting it in May, it has only worked for a few months - took ages to get it connected, and stopped working again in November. Horrible


the most frustrating part my end was that Vodafone refused to contact apple support directly when i spoke to both parties and were happy just to close the case and offer me compensation for all the issues i had, it never got resolved in the end and i just gave up. worst experience i have ever had trying months on end to get my watch connected, and for a company the size of vodafone not one person was able to resolve it which is poor.

After amaking contact with the social media team through Vodafone UK on Instagram. My issue was sorted within a week, very easy to communicate through that platform being able to send screen shots and not being able to answer straight away to questions due to work. Will be using this service over the annoying bot and call centres in the future.