main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal

This is a locked archive and content on this page may no longer be up to date. These posts and threads have been archived for reference only.

Archive

moto 4g wifi issues

SOLVED
View solved solution
Highlighted
2: Seeker

Hi all

 

Got a very strange issue with a moto 4g lte

 

I have a sim only deal with Vodafone

 

The phone works fine but for some reason when I'm connected to wifi it will connect to the Internet and i can search Google etc but when i try and do anything with a google product like gmail or the store the phone will not connect. If i turn off wifi and go to 4g it works. 

 

I've tried factory rest

checked date and time as per other advice on the net

I've tried my work phone sim

I've tethered to work phone via wifi and same issue

I've tried apn settings

I've tried switching to 3g

 

All of these have not worked. .. It's completely foxed me so can anyone help? 

 

View more options
1 ACCEPTED SOLUTION

Accepted Solutions
2: Seeker
Ok after some investigation it was a dns issue
got to wifi
choose modify settings of selected wifi (or when setting up new) - then select advanced settings.
Change to static
change dns1 to 8.8.8.8.8
change dns2 to 8.8.4.4

Save

Done :-)
View more options
3 REPLIES 3
17: Community Champion

That does sound horribly like a fault and I feel a repair coming on.  As well as tethering, I asume you've tried other wifi networks, just as a final rule-out?

View more options
2: Seeker

Need to investigate over the weekend how it works with other networks etc (use my work phone in the week)

Bought via Amazon so will just have to send it back for a replacement I guess

View more options
2: Seeker
Ok after some investigation it was a dns issue
got to wifi
choose modify settings of selected wifi (or when setting up new) - then select advanced settings.
Change to static
change dns1 to 8.8.8.8.8
change dns2 to 8.8.4.4

Save

Done :-)
View more options