main_icn_My_Vodafone main_icn_Search main_icn_Chevron_right main_icn_Chevron_down main_icn_Close main_icn_Menu social-facebook social-google-plus social-linkedin social-twitter social-youtube main_icn_Community_or_Foundation main_icn_Location main_icn_Network_signal
Menu Toggle

Welcome to Vodafone Community

Announcements
Keeping the UK connected is our main priority. Find out how we're doing thishere.
Close announcement

Mobile Broadband

Problems connecting iPhone to gigacube

2: Seeker

I have a 4g gigacube on my boat which works great on my SkyQ  and Xbox. The only problem is it seems to struggle to connect to my iPhone X. When I connect it to the gigacube it seems to take about 15 mins for it to be able to load a web page. Once connected it works fine but just very slow at first. Am I doing something wrong?

View more options
6 REPLIES 6
Highlighted
Moderator

Hey @Jonathaan76, that's a weird one - I must admit. Does it happen everywhere you are or are you permanentaly moored? As this could be a network issue in your area. 

View more options
Highlighted
2: Seeker

No I don't move the boat that often so it's always in the same place. There is nothing wrong with the signal as I live very close to Nottingham city. 

View more options
Highlighted
2: Seeker

Also when my phone is not connected to the gigacube and is connected to the Vodafone 4g it works absolutely fine. 

View more options
Highlighted
Moderator

Hey @Jonathaan76 Is it just your phone that has problems connecting, or does anyone else struggle to connect to your Gigacube too?

View more options
Highlighted
2: Seeker

It's 2 iPhones everything else connects fine. The problem seems to be mine and my partners iPhone. 

View more options
Highlighted
Moderator

Sounds like we may need to look into the settings on your phones @Jonathaan76, as we may need you to provide some screenshots of these while we do this, please pop us a message on Facebook or Twitter and I'm sure we'll get everything sorted for you. 

View more options