Showing results for 
Search instead for 
Did you mean: 






Fire Stick getting no internet connection

2: Seeker
2: Seeker

Hi, as of today, my fire stick is not connecting to our home broadband. This has been working fine since I had the broadband installed over a year ago. Today it is saying that it is connected to the WiFi with good signal strength and “channel 11 quality” however there is no internet connection 


I have connected the stick to the internet via my phone becoming a hotspot but I am getting nothing on my home broadband - this tells me that the stick itself is fine 


I can see the stick in my Vodafone broadband app also 



Hi @Swilcock8, are all your other WiFi devices connected and working okay? When you connected the Fire Stick using the mobile data from your phone, did you get connection? Could you also tell us what broadband package you have please? 🙂

Hi Mark 

Yes, all other devices are working with no issue and I achieved connection with no issue through mobile tethering 

My package is listed as “superfast 2”

Community Manager
Community Manager

You should have no problems connecting your Fire stick on your package @Swilcock8 and as you've advised, it's been connected previously. Are you getting a specific error message when you're trying to connect?

i just keep getting the following. I have tried resetting the stick, resetting the internet, but still I get nothing. 


Moderator (Retired)
Moderator (Retired)

Thank you very much for getting back to us with this image @Swilcock8. We'd like to help you take a closer look at the account and get to the bottom of what's going on here. So we can get the ball rolling, please drop us a message over on Twitter or Facebook here and we'll get started 👍

I'm getting the same problem.  Yesterday I was with TalkTalk and everything was working, Today I've moved to Vodafone and although wifi works on 2 laptop, 2 phones, and 2 android tabs my firestick gets the 'No Internet' message.  I also have a Roku Express which I have yet to try.

I've tried just about everything, including a factory reset on the firestick (new message is it can't set up because it can't connect to amazon), rebooting the router, splitting my SSIDs, using a wifi monitor on my phone close to the firestick (to check signal), but can't find the cause.

I've downloaded and installed the vodafone broadband app - but it doesn't show any devices, including working ones.

I've connected a second router closer to the firestick to check it with a stronger signal and still got the 'No Internet' message.  I had previously connected this same router to my TalkTalk router, in the same place and for a similar reason (signal strength) and everything worked fine.

I've started a 2 year contract Today and really don't want to go 2 years without things working as they should.

Community Manager
Community Manager

Hi @JPBonner - I'd love to help 🙂 I think the best thing would be to come and chat to my team on social media so we can go through some troubleshooting steps and to check things from our side too. 

I managed to get this sorted out after a fairly long chat session using TOBi.  In the end what was needed was a firmware upgrade on the router, which the agent did remotely.  I don't know whether it was an update to a later version (but that would seem strange on a new router) or if a patch was applied to allow a firestick to work with the router (opening ports?).  My Roku express is also now working.

Community Manager
Community Manager

Thanks for the update @JPBonner, I'm glad to hear we got everything sorted for you 😁