Showing results for 
Search instead for 
Did you mean: 






Vodafone router setup for Synology NAS

3: Seeker
3: Seeker

Hi there

I have a Synology DS215j NAS that I am trying to set up with my Vodafone router.

Before I changed to Vodafone, my router worked with my previous Broadband supplier.  Since I have changed over, I cannot access my router remotely from an external computer. 

It seems like my NAS cannot connect through the router.


Any help would be much appreciated.


Hi, yes you need to do the following:


1. Go to control panel, network and click manually enter DNS server

2. enter in the first box and in the second box (alternative)


when you have done this, when changing routers for some reason you have to force refresh the synology. You need to do the following :-


1. click control panel, network

2. click network interface tab on the top 

3. click on the applicable LAN connection and press edit

4. change to use manually configuration and press save.

5. Change back to get network configuration automatically and press save.

6. This then forces the synology to refresh all network settings, if you go to quick connect settings you will see its talking again with the outside world. 


View solution in original position


2: Seeker
2: Seeker

The easiest way is to set the NAS up for Quick connect and register an account with Synology. Pass through worked fine for me on their router and now a TP Link Archer V900.

I tried to set up my DS418, but at the same problem as the OP - if I remember it was a port forward issue. 

Same answer, Quick connect sorted it without getting in to port forwarding. Access through Synology apps is straightforward with a Quick connect user name.

I cannot enable QuickConnect on the Synology NAS  as I get the error shown in the attached photo.

I have manually configured the DNS server on the router to and still no joy.


Everything worked before I changed to the Vodafone router, QuickConnect, remote access etc.



Moderator (Retired)
Moderator (Retired)

@onlymeagain It's disappointing to hear you're having some problems with your router and connecting your NAS to it. While the router has the functionality to allow file sharing, we don't provide direct support for this type of use, as it's deemed as a complex setup. I'm sorry for any inconvenience this may cause. 

I seem to remember that there were other people having the same problem connecting their NAS through the Vodafone router.   The response was that the changes could not be displayed in the forum and had to be sent by private message, is this not the case?


I find it difficult that the router cannot be configured and Vodafone do not provide direct support for this type of use, as it is deemed a complex setup.  Surely it cannot be that difficult, can it?



Can you access the NAS ok locally? 

Do you get the DNS error when setting up Quick connect in the NAS settings or when trying to access it? 

I've ditched the Vodafone router so I can't check that it still works but it was working earlier this year.

Yes, accessing the NAS locally is not a problem.


I get the DNS error when I am trying to set up the QuickConnect in the NAS settings.


Do you remember if you had to change any of the settings on the Vodafone router when you had it?



I'm having the exact same issue and can't setup quick connect as it says:


"Domain can;t be resolved. Please change your DNS to"


I have done this but it still doesn't work. 


Has anyone got it to work?